I just bought a Dell Inspiron 7567 and I am trying to install Ubuntu 14.04, 16.04, 17.04, ...

I can see the grub menu, where I can select the options, but sometimes it crushes even before Ubuntu Live loads, others once it's loaded, and I cannot run any program and I just can reboot and start over again.

I've disabled secure boot, added nomodeset in the boot options, ... but nothing works.

I don't think the problem is about the bootable USB, as I used several of them and I have the issue with all of them.

A bit more of info. The computer comes with windows 10 installed in a m.2 ssd. I bought a ssd drive where I plan to install Linux

It's getting kind of frustrating/disappointing, I start thinking that I will have to stay with Windows until there is a new linux version that does not have all this problems

Has anyone succeeded in installing Ubuntu in this same model? Could you please help me? Could you tell me the steps I have to follow?

Any help/advise will be much appreciated

Bounty Update

My 512 GB ssd failed to boot ubuntu installed via UEFI boot mode. my dell bios configuration looks like,

SATA: AHCI (without this setting, I cant see my ssd on ubuntu live usb) secure boot: disabled boot mode: UEFI

I managed to install ubuntu 16.04 via live uefi usb stick. But I can't boot from ssd. On the boot option, I tried creating a new boot menu which pointing to efi/ubuntu/shim64x.efi but no results. Still I'm getting the below error.

Product Name: Dell Inspiron 15 7000 Gaming

No bootable devices found

I also tried, chroot into the installed ubuntu from live usb and changed the kernal boot parameters like below,


but still I got the same boot error "No bootable devices found". Some says SSD won't support legacy ROMs that's why I'm sticking to UEFI.

  • did you check the md5sums of the iso ?
    – Panther
    Sep 16, 2017 at 16:16
  • Yes, I checked the md5sum Sep 16, 2017 at 20:02
  • I've tried different tools to create the bootable USB: unetbootin, rufus, Universal USB Installer, ... with same results :( Sep 16, 2017 at 20:06
  • You must be doing something wrong then. I mean, is a user's illiteracy issue rather than a Ubuntu's "problem". Yes, you may need nomodeset for the gaming series that include a Nvidia graphics card but regardless of that eventual additional step, the problem boils down to how you're doing and booting the installation media. This is what you need to know: help.ubuntu.com/community/UEFI
    – user692175
    Sep 17, 2017 at 21:12
  • Thanks for answering @MichaelBay, I do not think it is a illiteracy issue. I~ have tried to remove the ssd with windows, so I have my second and empty ssd on my laptop. Tried to install it also in legacy mode, and same results. Sep 18, 2017 at 10:30

2 Answers 2


I just setup my Dell 7567 with dual boot for Windows 10 and Ubuntu 16.04. My setup involves keeping windows 10 in the ssd( Tiny 128 GB version) and installing Ubuntu on the Mechanical Drive( 1 Tb). Following are the steps I followed.

  1. Disable Fast Boot and Hibernate on Windows 10.

  2. Advanced startup, Enter BIOS and disable Secure Boot.

  3. In the BIOS there should be an option called SATA Operation Mode, switch that to AHCI( DEfault is RAID). Please Note: If the setting is not available on your BIOS you might need a BIOS update.

  4. Setup your Ubuntu 16.04 usb boot drive using rufus. Note: Create using the 'MBR partiton scheme for BIOS or UEFI Computers' option.

  5. Go to advanced Start Up and boot from the created USB.

  6. Once installation starts go for 'Something Else' on the installation window. Make sure the grub(bootloader) is installed in the drive with your Windows installation. Create your root partition and swap area in the new drive(Follow Tutorials).

  7. Continue with installation and try to download third party updates while installing( That will solve any driver issues with the graphics card)

  8. Reboot and you are good to go.

  • Thanks for you answer. The only difference between you and me is the second drive, yours is mechanical and mine is SSD. I think it's an hardware incompatibility issue, but I will try again replicating your steps Oct 23, 2017 at 7:48
  • sorry it's not working for me. Dec 21, 2018 at 13:46
  • @AvinashRaj Have you tried switching kernel? Have you read this Dell Inspiron 7567 - Linux Kernel Support ?
    – Kulfy
    Dec 21, 2018 at 14:09
  • Should be using 18.04 not older versions. And you must update UEFI, update SSD firmware & change to AHCI all mentioned above. Similar models are essentially the same with Dell. Post installation issues Ubuntu 18.04-Dell inspiron 7559 askubuntu.com/questions/1072382/… Dell Inspiron 7566 ubuntuforums.org/showthread.php?t=2342359
    – oldfred
    Dec 21, 2018 at 15:16
  • @Kulfy not yet.. Currently I have 18.04 iso image . Do I need to download the ubuntu version corresponding to v4.9.111 ? Dec 21, 2018 at 15:58

This is an abandoned question. The user who posted it hasn't signed on in over a year. An answer is needed for a different user who posted a bounty as such comments need to be addressed to: Avinash Raj

I don't have a Dell Inspiron 15 7567. But I do have a Dell Inspiron 17R 7720 SE (Ivy Bridge i7-3630QM) and a Dell Alienware 17R3 (Skylake i7-6700 HQ) with NVMe SSD. The "Dell way" is very similar with both laptops.

My AW17R3 came with a 1 TB HDD. I immediately bought a Samsung Pro 960 NVMe SSD though for greater speed. To install to the SSD I did the following:

  • Remove HDD so BIOS doesn't become "confused".
  • Install M.2 NVMe PCIe Gen 3.0 x 4 (bubble gum stick) SSD.
  • Boot with freshly created Windows 10 Installation USB flash drive.
  • Install Windows 10.
  • Download and install 6 or more Dell drivers for Windows 10 and my laptop. This is very important because Windows drivers update BIOS and firmware that Linux benefits from.
  • Boot with Ubuntu 16.04 Installation USB flash drive.
  • Some say secure boot must be off but it works OK with it on these days.
  • Some say to switch from Intel RST to AHCI but it worked OK without switching. Note for me switching to AHCI to I needed to reinstall Ubuntu but not Windows 10. However after switching to AHCI, I couldn't switch back for some reason.
  • Next step was to reinstall HDD which becomes the secondary drive and SSD is now the primary boot drive.
  • After installing Ubuntu 16.04 grub wouldn't boot Windows 10 until I ran `boot-repair.
  • After running boot-repair I ended up with extra Windows boot options that didn't belong so I followed this: Boot Repair created too many Grub menu entries for Windows

The error message reported in comments: "no boot device found" can mean many things. There are some good Youtube videos that addresses the problem:

This video isn't as good but may help:

  • Added some updates on the original question. Dec 23, 2018 at 3:49
  • after doing bios update, it works for me. Thanks.. Dec 23, 2018 at 13:49
  • @AvinashRaj Great news. One of the reasons I recommend users only shrink Windows down and never delete it is for applying BIOS and firmware updates. Dec 23, 2018 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.