0

I have a 20mb/s wifi connection and it works properly unless I connect my bluetooth speaker. when I do that the wifi connection slows down and poorly work. I've already tryed this solution and this other one but none of that worked. I'm running a Ubuntu 16.04 on a Dell Inspiron 14300.

The outputs for lspci -knn | grep Net -A2 are:

06:00.0 Network controller [0280]: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036] (rev 01)
Subsystem: Dell QCA9565 / AR9565 Wireless Network Adapter [1028:020c]
Kernel driver in use: ath9k
Kernel modules: ath9k

And also, the outputs for lsusb are:

Bus 001 Device 006: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 007: ID 0cf3:0036 Atheros Communications, Inc. 
Bus 001 Device 004: ID 0bda:5756 Realtek Semiconductor Corp. 
Bus 001 Device 003: ID 062a:4102 Creative Labs 
Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I don't know what else I can do to fix it.

3

You can enable BT coexistence in the ath9k module.

Run in a terminal

sudo tee /etc/modprobe.d/ath9k.conf <<< "options ath9k btcoex_enable=1"

and reboot.

This helps in most cases. The ath9k BT coex algorithm is good. It is a shame that it isn't enabled by default yet.

|improve this answer|||||
  • makes sense that it should be enabled by default – ravery Sep 16 '17 at 14:36
  • Long ago it didn't work well on some devices, that's why they didn't enable it. With Intel devices it works poorly, but is enabled. – Pilot6 Sep 16 '17 at 14:37
  • I remember 14.04 didn't have the ath9k firmware, I had to go find it. If I remember correctly intel's firmware worked :) – ravery Sep 16 '17 at 14:43
  • 1
    @Pilot6, Like I said, it worked at first try, but past some time the wifi connection started fail again... – roooooon Sep 16 '17 at 20:48
  • 1
    Not worked for me with ubuntu 18.04 – Morteza Ziyae Oct 20 '18 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.