0

I just installed the latest Desktop OS Ubuntu 16.04.03 LTS. After install, I cannot connect to the internet.

I tried to ping google.com and it says ping: unknown host google.com.

I tried to ping google's IP 172.217.25.14 and also their DNS 8.8.8.8 and the connection is successful.

I think the problem is with my DNS. I already reinstalled Ubuntu with the same results. I can also Ping and even browse my local router at 192.168.1.1. The machine has a valid IP address (from the router). And there is not problem with my internet (there are other computers that are connected to the network and can connect to the internet).

I've got this installed on an ASUS P8Z68-V PRO/GEN3 motherboard. I'm using the onboard LAN.

I cannot browser, the system cannot update because it cannot connect to the internet. Again I think this is somewhere around name resolution but I just can't put my finger on it.

Thanks for the help.

0

As suspected, the problem was DNS related.

I was able to fixed by manually providing my DNS Servers.

Go to your Network Connections then look for IPv4 Settings and change Method from Automatic (DHCP) to **Automatic (DHCP) addresses only**.

Then below this, in the DNS servers section, enter your preferred DNS. I used Google's DNS 8.8.8.8, 8.8.4.4. Separate your DNS with a comma.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.