0

This question already has an answer here:

i am using hp ay503tx there is A problem with my wifi , wifi is detecting the networks but not all available neworks . and couldn't connect with them

my network detail is

 *-network
            description: Wireless interface
            product: RTL8723BE PCIe Wireless Network Adapter
            vendor: Realtek Semiconductor Co., Ltd.
            physical id: 0
            bus info: pci@0000:03:00.0
            logical name: wlo1
            version: 00
            serial: 3c:a0:67:76:a9:b5
            width: 64 bits
            clock: 33MHz
            capabilities: bus_master cap_list ethernet physical wireless
            configuration: broadcast=yes driver=rtl8723be driverversion=4.10.0-33-generic firmware=N/A ip=192.168.43.165 latency=0 link=yes multicast=yes wireless=IEEE 802.11
            resources: irq:17 ioport:3000(size=256) memory:b1100000-b1103fff

marked as duplicate by Pilot6, Organic Marble, karel, Eric Carvalho, user364819 Sep 18 '17 at 21:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • did you try the lwfinger drivers? github.com/lwfinger/rtlwifi_new – ravery Sep 15 '17 at 13:08
  • This post helped me: askubuntu.com/a/883688/3940 – Takkat Sep 15 '17 at 13:17
  • i have downloaded the file could help me with installation, when i unzip it and move inside it and open termilnal and type sudo make install it says make -C /lib/modules/4.10.0-33-generic/build M=/home/rizwan/Downloads/rtlwifi_new-master modules make[1]: *** /lib/modules/4.10.0-33-generic/build: No such file or directory. Stop. Makefile:58: recipe for target 'all' failed make: *** [all] Error 2 – Rizwan Sep 15 '17 at 14:04
0

It same wifi card's chip with mine (RTL8723BE).. first open your terminal and type :

sudo nano /etc/modprobe.d/rtl8723be.conf

and then copy this code :

options rtl8723be ant_sel=1

and then press ctrl+x, choose 'Y' and then hit [enter] now type again the command on your terminal :

sudo modprobe -rv rtl8723be

wait until finish and type again this code :

sudo modprobe -v rtl8723be

and try the wifi to connect to the Access point.

if it doesn't work, try again step by step but change this code: from :

options rtl8723be ant_sel=1

to

options rtl8723be ant_sel=2

or

options rtl8723be ant_sel=0

it's work for me, I hope t will work for yout too,,,

Not the answer you're looking for? Browse other questions tagged or ask your own question.