9

Two days ago (after an Ubuntu base update, iirc), all music and video files on my computer stopped playing. Clementine and Videos open them, but won't play them - no error message, no request for plugins.
At the same time, YouTube clips have stopped playing - I just get the thumbnail, the rotating "waiting" sign and the message "if playback doesn't begin shortly, try restarting your device" (which, of course, doesn't work). This is Ubuntu 14.04.
Details:

  • I do have gstreamer0.10-plugins-good and ubuntu-restricted-extras. Tried reinstalling (together with Clementine and Videos) - no good.
  • Videos can clearly "read" the video file, since I can navigate through it and the still picture shown changes.
  • My speakers are recognised.
  • Pressing "pause" then "play" again doesn't work.
  • Flash sound does work! Interestingly enough, right after the update, I could get no sound on clips streamed in a Flash window (they were running though, the video was fine). After restarting, the sound from streaming works just fine, but music/video files and YouTube clips don't.
  • I didn't install anything new or make any changes to Ubuntu before this happened.

2 Answers 2

17

Solved!
This is what worked:

killall pulseaudio; rm -r ~/.config/pulse/*

Wait a little, then

pulseaudio -k 

Then restart. Ta-dah! Now how to mark this "solved"...

7
  • 1
    To mark this as solved, accept your answer by clicking the tick on the left.
    – dessert
    Commented Sep 17, 2017 at 6:34
  • I can fix this with just the first command, no restart needed. But what could be the cause of this? it happens all the time in my 18.04 and I have to fix it as said. (Created a launcher with the line Exec=sh -c 'killall pulseaudio; rm -r ~/.config/pulse/*'.) It seems related to bluetooth headset connection in my case.
    – cipricus
    Commented Jun 4, 2019 at 18:54
  • 1
    Is there a permanent solution to this?
    – cipricus
    Commented Oct 8, 2019 at 9:48
  • None that I've found, I'm afraid. My only lead is something so silly I can only assume it's a coincidence: the problem stopped appearing when I set Firefox to no longer restore my session at startup. I've since changed laptops and moved on to Ubuntu 16.04, so it will probably remain a mystery.
    – mujina
    Commented Oct 9, 2019 at 18:12
  • @mujina In my case audio works from web app like youtube but local mp3 files are unable to play. After using your solution it works but I have to do it multiple times and every time restarting is not possible. can you help me with this?
    – Dhruv garg
    Commented Oct 27, 2020 at 11:57
0

I know this is an old thread, but since I am still affected by this issue in Ubuntu 22.04 and since I haven't able to find anywhere a solution, I am posting it here.

Killing pulseaudio didn't work for me, but killing pipewire and pipewire-media session did.

So, long story short, if killing pulseaudio doesn't work for you too, just try to kill pipewire and pipewire-media-session.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .