3

I've got two nearly-identical Ubuntu 16.04 LTS systems, installed from the same DVD.

https://hardwarerecs.stackexchange.com/questions/7624/can-someone-recommend-a-low-cost-linux-computer-with-a-hdd-and-some-ram-expandab/7625#7625

They basically act the same, but with one annoying difference.

On one of them I am getting the Unity menu on my login screen and in RDP sessions.

RDP sessions use Xfce and regular logins use gnome.

Here is a screenshot (logged in via RDP to Xfce desktop):

enter image description here

When I pull down Applications it works fine, but I should not be seeing that gnome menu down the left side at all. On the other system it doesn't show until I log into gnome.

It also shows it on the console login screen, but isn't functional until I log in.

In both cases (login screen on the console and RDP) it should not show at all, and is non-functional.

How do I set this back to normal?

2

What I understood is that you want to access the menu's settings and disable auto-hide, so it does not collapse with your Desktop shortcuts.

You have to open Settings > Appearance > click on Behavior tab:

enter image description here

Then, in order to disable menu auto-hiding, click on:

enter image description here

This will make your menu stay in one place but it will occupy some space of your screen. Atleast, it won't be annoying you.

  • 1
    Thanks for the post. This is useful information so Upvote. -- also figured out what was wrong with this system - the background image itself contained those icons. No idea how/why. But simply changing the background image from Xfce (Applications, Settings, Desktop) made them go away.. – SDsolar Sep 15 '17 at 14:52
  • That gave me a chuckle, I have to admit. Pranked by your own background image! – Organic Marble Sep 29 '17 at 17:29
  • I'm glad someone noticed it. It's the El Capitan rock, located on Yosemite National Park. Most users first saw it on Mac OS El Capitan. Appl* got a great picture of it. Look at these colors. – George Mathioudakis Sep 29 '17 at 18:00
0

Problem solved, but not sure why it happened in the first place.

Turns out that on the console before logging in it displays the Xfce desktop background as the image behind the login prompt. No problem.

Then when logged in via RDP it shows the same background.

Somehow it ended up with a background image that included those icons. No idea how. But that explains why they were non-functional.

Changing the background image within an RDP session to an one without them solved the problem.

Procedure in Xfce is: Applications, Settings, Desktop, then change background.

The image with the gnome icons was visible along with other normal wallpapers.

Perhaps it is possible the PrtSc button was pressed while logged into gnome which caused that screen to be added to the available desktop wallpaper choices in Xfce.

In any case, beware when looking through the available wallpapers in Xfce to prevent this from happening.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.