1

I cannot ssh to my server. When I try ssh localhost on the server I get a "connection refused" message. When I try remotely, I get Operation timed out message.

screen dump of my server running

2

According to the screenshot you are trying to connect to a port 22 however your server is configured to listen to port 22222. Just type ssh localhost -p 22222. Should work.

  • I've gone into the config file and changed the setting to 22. Now when I type "ssh localhost" I get a welcome message and then a Failed to connect to changlelogs.ubuntu.com/meta-release. Check your Internet connection or proxy settings. I was trying to add a screen dump to this message but can't do so. – Vincent Gledhill Sep 15 '17 at 7:41
  • And I still can't ssh remotely. I just get operation timed out. – Vincent Gledhill Sep 15 '17 at 7:43
  • How do you connect remotely to your server - using Putty for Windows or ssh command for Linux/MacOS? Also try to connect using IP address not DNS-name if you done so before. – M. Dm. Sep 15 '17 at 8:08
  • I am trying to connect remotely via SSH in terminal for MAC. I have tried both the IP address and the DNS-name to no avail. – Vincent Gledhill Sep 15 '17 at 9:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.