0

After a week of trying, I am very stuck at even finding a way to install required software via apt-get or apt. For example, when installing thunar, there is this error:

$ sudo apt install thunar
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package thunar is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'thunar' has no installation candidate

I have tried the following:

  1. sudo apt-get update --fix-missing
  2. sudo apt-get upgrade
  3. sudo apt-get dist-upgrade
  4. sudo apt-get autoremove
  5. sudo apt-get -f install

But there's still the same problem. I suspected it could be due to a huge mix up in sources.list, so I went to the software center and reverted the list by selecting the Best Server option. However, this did not help at all. In fact, when I tried this twice and got two different best servers, so I suspect it is not an issue of the servers.

Here is my current sources.list:

#------------------------------------------------------------------------------#
#                            OFFICIAL UBUNTU REPOS                             #
#------------------------------------------------------------------------------#


###### Ubuntu Main Repos
deb http://ftp.cuhk.edu.hk/pub/Linux/ubuntu/ xenial main restricted universe multiverse
deb-src http://ftp.cuhk.edu.hk/pub/Linux/ubuntu/ xenial main restricted universe multiverse

###### Ubuntu Update Repos
deb http://ftp.cuhk.edu.hk/pub/Linux/ubuntu/ xenial-security main restricted universe multiverse
deb http://ftp.cuhk.edu.hk/pub/Linux/ubuntu/ xenial-updates main restricted universe multiverse
deb http://ftp.cuhk.edu.hk/pub/Linux/ubuntu/ xenial-proposed main restricted universe multiverse
deb-src http://ftp.cuhk.edu.hk/pub/Linux/ubuntu/ xenial-security main restricted universe multiverse
deb-src http://ftp.cuhk.edu.hk/pub/Linux/ubuntu/ xenial-updates main restricted universe multiverse
deb-src http://ftp.cuhk.edu.hk/pub/Linux/ubuntu/ xenial-proposed main restricted universe multiverse

#------------------------------------------------------------------------------#
#                           UNOFFICIAL UBUNTU REPOS                            #
#------------------------------------------------------------------------------#


###### 3rd Party Binary Repos

#### Wine PPA - https://launchpad.net/~ubuntu-wine/+archive/ppa/
## Run this command: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 883E8688397576B6C509DF495A9A06AEF9CB8DB0
deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu xenial main


####### 3rd Party Source Repos

#### Wine PPA (Source) - https://launchpad.net/~ubuntu-wine/+archive/ppa/
## Run this command: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 883E8688397576B6C509DF495A9A06AEF9CB8DB0
deb-src http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu xenial main

From updating, I get the following error:

Err:102 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu xenial-security/main arm64 Packages                                                                                                                                                                                           
  404  Not Found [IP: 137.189.4.14 80]
Ign:112 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu xenial-security/universe arm64 Packages                                                                                                                                                                                       
Ign:63 http://ppa.launchpad.net/mc3man/trusty-media/ubuntu xenial/main DEP-11 64x64 Icons                                                                                                                                                                                     
Err:127 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu xenial-updates/main arm64 Packages                                                                                                                                                                                            
  404  Not Found [IP: 137.189.4.14 80]
Ign:137 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu xenial-updates/universe arm64 Packages                                                                                                                                                                                        
Ign:143 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu xenial-updates/multiverse arm64 Packages                                                                                                                                                                                      
Err:151 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu xenial-proposed/main arm64 Packages                                                                                                                                                                                           
  404  Not Found [IP: 137.189.4.14 80]
Ign:158 http://ftp.cuhk.edu.hk/pub/Linux/ubuntu xenial-proposed/universe arm64 Packages                                                                                                                                                                                       
Err:64 http://ppa.launchpad.net/richardgv/compton/ubuntu xenial/main Sources                                                                                                                                                                                                  
  404  Not Found
Ign:65 http://ppa.launchpad.net/richardgv/compton/ubuntu xenial/main amd64 Packages                                                                                                                                                                                           
Ign:66 http://ppa.launchpad.net/richardgv/compton/ubuntu xenial/main i386 Packages                                                                                                                                                                                            
Ign:67 http://ppa.launchpad.net/richardgv/compton/ubuntu xenial/main arm64 Packages                                                                                                                                                                                           
Ign:68 http://ppa.launchpad.net/richardgv/compton/ubuntu xenial/main all Packages                                                                                                                                                                                             
Ign:69 http://ppa.launchpad.net/richardgv/compton/ubuntu xenial/main Translation-en_US                                                                                                                                                                                        
Ign:70 http://ppa.launchpad.net/richardgv/compton/ubuntu xenial/main Translation-en                                                                                                                                                                                           
Ign:71 http://ppa.launchpad.net/richardgv/compton/ubuntu xenial/main amd64 DEP-11 Metadata                                                                                                                                                                                    
Ign:72 http://ppa.launchpad.net/richardgv/compton/ubuntu xenial/main DEP-11 64x64 Icons                                                                                                                                                                                       
Err:73 http://ppa.launchpad.net/varlesh-l/papirus-pack/ubuntu xenial/main Sources                                                                                                                                                                                             
  404  Not Found
Ign:83 http://ppa.launchpad.net/varlesh-l/papirus-pack/ubuntu xenial/main amd64 Packages                                                                                                                                                                                      
Ign:84 http://ppa.launchpad.net/varlesh-l/papirus-pack/ubuntu xenial/main i386 Packages                                                                                                                                                                                       
Ign:76 http://ppa.launchpad.net/varlesh-l/papirus-pack/ubuntu xenial/main arm64 Packages                                                                                                                                                                                      
Ign:77 http://ppa.launchpad.net/varlesh-l/papirus-pack/ubuntu xenial/main all Packages                                                                                                                                                                                        
Ign:78 http://ppa.launchpad.net/varlesh-l/papirus-pack/ubuntu xenial/main Translation-en_US                                                                                                                                                                                   
Ign:85 http://ppa.launchpad.net/varlesh-l/papirus-pack/ubuntu xenial/main Translation-en                                                                                                                                                                                      
Ign:80 http://ppa.launchpad.net/varlesh-l/papirus-pack/ubuntu xenial/main amd64 DEP-11 Metadata                                                                                                                                                                               
Ign:81 http://ppa.launchpad.net/varlesh-l/papirus-pack/ubuntu xenial/main DEP-11 64x64 Icons                                                                                                                                                                                  
Fetched 37.2 MB in 1min 11s (520 kB/s)                                                                                                                                                                                                                                        
Reading package lists... Done
W: file:///var/cuda-repo-8-0-local/Release.gpg: Signature by key 889BEE522DA690103C4B085ED88C3D385C37D3BE uses weak digest algorithm (SHA1)
W: Invalid 'Date' entry in Release file /var/lib/apt/lists/_var_cuda-repo-8-0-local_Release
W: Invalid 'Date' entry in Release file /var/lib/apt/lists/_var_libopencv4tegra-repo_Release
W: Invalid 'Date' entry in Release file /var/lib/apt/lists/_var_visionworks-repo_Release
W: Invalid 'Date' entry in Release file /var/lib/apt/lists/_var_visionworks-sfm-repo_Release
W: Invalid 'Date' entry in Release file /var/lib/apt/lists/_var_visionworks-tracking-repo_Release
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://build.openvpn.net/debian/openvpn/stable xenial Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8E6DA8B4E158C569
N: Skipping acquire of configured file 'main/binary-arm64/Packages' as repository 'https://apt.dockerproject.org/repo ubuntu-xenial InRelease' doesn't support architecture 'arm64'
W: GPG error: http://download.opensuse.org/repositories/home:/Horst3180/xUbuntu_16.04  Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 5A7D1D38BEB6D886
W: The repository 'http://download.opensuse.org/repositories/home:/Horst3180/xUbuntu_16.04  Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
N: Skipping acquire of configured file 'stable/binary-arm64/Packages' as repository 'https://www.perfect-privacy.com/repos/linux/debian perfect-privacy-vpn InRelease' doesn't support architecture 'arm64'
W: The repository 'http://ppa.launchpad.net/mc3man/trusty-media/ubuntu xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: The repository 'http://ppa.launchpad.net/richardgv/compton/ubuntu xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: The repository 'http://ppa.launchpad.net/varlesh-l/papirus-pack/ubuntu xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: Failed to fetch http://build.openvpn.net/debian/openvpn/stable/dists/xenial/Release.gpg  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8E6DA8B4E158C569
E: Failed to fetch http://ftp.cuhk.edu.hk/pub/Linux/ubuntu/dists/xenial/main/binary-arm64/Packages  404  Not Found [IP: 137.189.4.14 80]
E: Failed to fetch http://ftp.cuhk.edu.hk/pub/Linux/ubuntu/dists/xenial-security/main/binary-arm64/Packages  404  Not Found [IP: 137.189.4.14 80]
E: Failed to fetch http://ftp.cuhk.edu.hk/pub/Linux/ubuntu/dists/xenial-updates/main/binary-arm64/Packages  404  Not Found [IP: 137.189.4.14 80]
E: Failed to fetch http://ftp.cuhk.edu.hk/pub/Linux/ubuntu/dists/xenial-proposed/main/binary-arm64/Packages  404  Not Found [IP: 137.189.4.14 80]
E: Failed to fetch http://ppa.launchpad.net/mc3man/trusty-media/ubuntu/dists/xenial/main/source/Sources  404  Not Found
E: Failed to fetch http://ppa.launchpad.net/richardgv/compton/ubuntu/dists/xenial/main/source/Sources  404  Not Found
E: Failed to fetch http://archive.ubuntukylin.com:10006/ubuntukylin/dists/xenial/main/binary-arm64/Packages  404  Not Found
E: Failed to fetch http://ppa.launchpad.net/varlesh-l/papirus-pack/ubuntu/dists/xenial/main/source/Sources  404  Not Found
W: Some index files failed to download. They have been ignored, or old ones used instead.

And the 'Failed to fetch' error is consistent even after changing servers to the main one. I have completely no idea why this happens.

Threads I have looked at:

  1. Choosing best server: 'apt-get update' Error
  2. Purging problematic packages (thunar in this case): Can't apt-get anything
  3. Unmet dependencies: How to resolve Unmet dependencies error?

Is there anything I can do to resolve this? I am currently surviving on existing packages that I could install before downloading got issues. Hope there's an expert out there who could diagnose and solve this problem.

Thank you.

Edit 1: Why my question is not a duplicate of How do I fix the GPG error "NO_PUBKEY"?

I tried the solution and got this problem instead:

$ sudo apt-get install y-ppa-manager
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 y-ppa-manager : Depends: yad (>= 0.36.0) but it is not going to be installed
                 Depends: ppa-purge but it is not installable
                 Depends: xclip but it is not installable
E: Unable to correct problems, you have held broken packages.

Additional Error when using Software & Updates, which is happens when the application requires me to reload after changing the servers etc.:

W:Target Sources (main/source/Sources) is configured multiple times in /etc/apt/sources.list:34 and /etc/apt/sources.list.d/ubuntu-wine-ubuntu-ppa-xenial.list:2, W:Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:27 and /etc/apt/sources.list.d/ubuntu-wine-ubuntu-ppa-xenial.list:1, W:Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:27 and /etc/apt/sources.list.d/ubuntu-wine-ubuntu-ppa-xenial.list:1, W:Target Packages (main/binary-arm64/Packages) is configured multiple times in /etc/apt/sources.list:27 and /etc/apt/sources.list.d/ubuntu-wine-ubuntu-ppa-xenial.list:1, W:Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:27 and /etc/apt/sources.list.d/ubuntu-wine-ubuntu-ppa-xenial.list:1, W:Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:27 and /etc/apt/sources.list.d/ubuntu-wine-ubuntu-ppa-xenial.list:1, W:Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list:27 and /etc/apt/sources.list.d/ubuntu-wine-ubuntu-ppa-xenial.list:1, W:Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:27 and /etc/apt/sources.list.d/ubuntu-wine-ubuntu-ppa-xenial.list:1, W:Target Packages (Packages) is configured multiple times in /etc/apt/sources.list.d/vertex-theme.list:1 and /etc/apt/sources.list.d/vertex-theme.list:2, W:Target Translations (en) is configured multiple times in /etc/apt/sources.list.d/vertex-theme.list:1 and /etc/apt/sources.list.d/vertex-theme.list:2, W:file:///var/cuda-repo-8-0-local/Release.gpg: Signature by key 889BEE522DA690103C4B085ED88C3D385C37D3BE uses weak digest algorithm (SHA1), W:Invalid 'Date' entry in Release file /var/lib/apt/lists/_var_cuda-repo-8-0-local_Release, W:Invalid 'Date' entry in Release file /var/lib/apt/lists/_var_libopencv4tegra-repo_Release, W:Invalid 'Date' entry in Release file /var/lib/apt/lists/_var_visionworks-repo_Release, W:Invalid 'Date' entry in Release file /var/lib/apt/lists/_var_visionworks-sfm-repo_Release, W:Invalid 'Date' entry in Release file /var/lib/apt/lists/_var_visionworks-tracking-repo_Release, W:Skipping acquire of configured file 'main/binary-arm64/Packages' as repository 'https://apt.dockerproject.org/repo ubuntu-xenial InRelease' doesn't support architecture 'arm64', W:GPG error: http://build.openvpn.net/debian/openvpn/stable xenial Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8E6DA8B4E158C569, W:The repository 'http://build.openvpn.net/debian/openvpn/stable xenial Release' is not signed., W:Data from such a repository can't be authenticated and is therefore potentially dangerous to use., W:See apt-secure(8) manpage for repository creation and user configuration details., W:Skipping acquire of configured file 'main/binary-arm64/Packages' as repository 'http://build.openvpn.net/debian/openvpn/stable xenial InRelease' doesn't support architecture 'arm64', W:GPG error: http://download.opensuse.org/repositories/home:/Horst3180/xUbuntu_16.04  Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 5A7D1D38BEB6D886, W:The repository 'http://download.opensuse.org/repositories/home:/Horst3180/xUbuntu_16.04  Release' is not signed., W:Data from such a repository can't be authenticated and is therefore potentially dangerous to use., W:See apt-secure(8) manpage for repository creation and user configuration details., W:Skipping acquire of configured file 'stable/binary-arm64/Packages' as repository 'https://www.perfect-privacy.com/repos/linux/debian perfect-privacy-vpn InRelease' doesn't support architecture 'arm64', W:The repository 'http://ppa.launchpad.net/mc3man/trusty-media/ubuntu xenial Release' does not have a Release file., W:Data from such a repository can't be authenticated and is therefore potentially dangerous to use., W:See apt-secure(8) manpage for repository creation and user configuration details., W:The repository 'http://ppa.launchpad.net/richardgv/compton/ubuntu xenial Release' does not have a Release file., W:Data from such a repository can't be authenticated and is therefore potentially dangerous to use., W:See apt-secure(8) manpage for repository creation and user configuration details., W:The repository 'http://ppa.launchpad.net/varlesh-l/papirus-pack/ubuntu xenial Release' does not have a Release file., W:Data from such a repository can't be authenticated and is therefore potentially dangerous to use., W:See apt-secure(8) manpage for repository creation and user configuration details., W:Failed to fetch http://....archive.ubuntu.com/ubuntu/dists/xenial/InRelease  Could not resolve '....archive.ubuntu.com', W:Failed to fetch http://....archive.ubuntu.com/ubuntu/dists/xenial-security/InRelease  Could not resolve '....archive.ubuntu.com', W:Failed to fetch http://....archive.ubuntu.com/ubuntu/dists/xenial-updates/InRelease  Could not resolve '....archive.ubuntu.com', W:Failed to fetch http://....archive.ubuntu.com/ubuntu/dists/xenial-proposed/InRelease  Could not resolve '....archive.ubuntu.com', E:Failed to fetch http://ppa.launchpad.net/mc3man/trusty-media/ubuntu/dists/xenial/main/source/Sources  404  Not Found, E:Failed to fetch http://ppa.launchpad.net/richardgv/compton/ubuntu/dists/xenial/main/source/Sources  404  Not Found, E:Failed to fetch http://ppa.launchpad.net/varlesh-l/papirus-pack/ubuntu/dists/xenial/main/source/Sources  404  Not Found, E:Failed to fetch http://archive.ubuntukylin.com:10006/ubuntukylin/dists/xenial/main/binary-arm64/Packages  404  Not Found, W:Some index files failed to download. They have been ignored, or old ones used instead.
  • Why do you have arm64, amd64 and i386 all enabled? O.o – muru Sep 14 '17 at 15:09
  • @muru I think this happened when I was developing for an aarch64 platform (Jetson TX1). I'm not too sure why it happens or how to manually disable it since it's not in the sources.list – lee kwot sin Sep 14 '17 at 15:26
  • @karel I think the GPG is giving a warning but not an error, although I'm not sure if they still cause a problem. – lee kwot sin Sep 14 '17 at 15:29
  • 1
    thunar is in the universe repository, which you do not seem to have enabled in your sources.list. – Charles Green Sep 14 '17 at 15:40
  • @CharlesGreen the universe words are in the main and update repos, is that sufficient or should I add a new repository? – lee kwot sin Sep 14 '17 at 16:38
1

You have a number of errors in your software sources, some of which are related to upgrading your system to Xenial. In particular, the sources at

http://ftp.cuhk.edu.hk do not have a release for the arm64 architecture, and

http://ppa.launchpad.net/richardgv/compton
http://ppa.launchpad.net/varlesh-l/papirus-pack
http://ppa.launchpad.net/mc3man/trusty-media

Do not have releases for Xenial, and several others compain about not having arm64 releases.

Finally, you include several archives from OpenSuse, and apparently have a local archive for Cuda, which reports some errors.


Quick Fix: Open "Software & Updates", go to the Other Software tab and uncheck (disable) the third party archives that are reporting that they are not available. From the CLI if you would prefer, you can edit /etc/apt/sources.list and place a # on the offending line, but you may need to edit files in /etc/apt/sources.list.d if the corresponding lines are not present in /etc/apt/sources.list


This will not fix the problem of some repositories reporting that they do not have arm64 releases: You should evaluate if you need that architecture for what you are doing, and possibly remove the architecture from your system:

sudo dpkg --remove-architecture arm64

If you have installed arm64 packages, you will need to remove them first:

sudo apt-get purge ".*:arm64"

Longer Fix: As you have indicated in the comments that you need to retain some of the packages that use arm64 architecture, you will need instead to edit every source in /etc/apt/sources.list and /etc/apt/sources.list.d/*.list which produces an error related to the arm64 architecture, to include the words [arch=amd64] or [arch=amd64,i386]

For example, you must find a line in your sources reading

deb http://ftp.cuhk.edu.hk/pub/Linux/ubuntu xenial-security main

and change this line to

deb [arch=amd64,i386] http://ftp.cuhk.edu.hk/pub/Linux/ubuntu xenial-security main

This will instruct apt to load only the amd64 and i386 architectures for that source, and not try to load the arm64 architecture (which is not there, and what apt is warning about)


Finally, if you need packages from some of the deactivates sources, such as the cuda package, you will need to research how to add these sources appropriately for you Xenial system.

  • Using sudo apt-get purge ".*:arm64" will also remove my CUDA 8.0 toolkit as it says that some files do not have the "arm64" name to it and so they refer to the original software which I want to keep. Is keeping arm64 a source of the problem? Unfortunately after nearly unchecking all of the third party softwares, the same error still comes up – lee kwot sin Sep 14 '17 at 18:21
  • I'll update the answer in about 20 minutes (cooking some jambalaya – Charles Green Sep 14 '17 at 22:10
  • Added a section to change the architecture for individual PPAs - look for Longer Fix – Charles Green Sep 14 '17 at 22:24
  • I noticed that unchecking some boxes in the Other Software section is linked to the sources.dlist, is this true? if so, do you know which boxes should be checked by default? I tried unchecking all and it seems some important repos get removed as well. Will purging the arm64 solve the main problem of not being able to download rather than addressing just the warnings? – lee kwot sin Sep 15 '17 at 12:06
  • Update: I have purged arm64 but the problem persists. I found that the problem could be due to an installation of JetPack from NVIDIA as seen here: devtalk.nvidia.com/default/topic/1003434/… Is there a solution to this? – lee kwot sin Sep 15 '17 at 12:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.