After running conjure-up, and choosing OpenStack with LXD, when I try to deploy to localhost I get this error

Could not locate any network or storage devices to continue. Please make sure you have at least 1 network bridge and 1 storage pool.

When I run lxc network list I have the following

NAME    TYPE   MANAGED DESC USEDBY

docker0 bridge NO             0

eth0 physical  NO  -          0

lxdbr0 bridge YES   -         1


When I run lxc storage list I have the following

NAME-default

DESC -

DRIVER - dir

SOURCE - /var/lib/lxd/storage-pools/default

USED BY -2

Also on running lxc list the output is as below

NAME - valued-kangaroo

STATE - RUNNING

IPV4  - 10.x.x.x (eth0)

IPV6 - 

TYPE - PERSISTENT

SNAPSHOTS -0

Where am I going wrong?

Thanks !

Ubuntu Version: 64 Bit 16.04LTS

up vote 4 down vote accepted

I encountered the same issue on Ubuntu 16.04 and found out there is a compatibility issue with LXD (default Ubuntu's lxd or installed via snap) and conjure-up. Conjure-up could not access LXD containers or something (look into the logs). So what I did to make it to work is to install the latest LXD from its PPA and start the conjure-up again.

1. It's better to have a fresh server to start with so I re-installed Ubuntu 16.04t

2. Instead of using the default LXD, I added the LXD's stable PPA and upgraded it (important):

$ sudo apt-add-repository ppa:ubuntu-lxc/stable
$ sudo apt update
$ sudo apt dist-upgrade
$ sudo apt install lxd zfsutils-linux

3. Configure LXD (important):

$ sudo lxd init

Just answer the questions using the default values except for the IPv6's one. Then you will have a bridge network interface (e.g. lxdbr0: 10.x.x.x) and a zfspool.

4. Disable IPv6 on all the network interfaces:

$ sudo sysctl -w net.ipv6.conf.lxdbr0.disable_ipv6=1
$ sudo sysctl -w net.ipv6.conf.enp2s0.disable_ipv6=1

Note: change lxdbr0 and enp2s0 to your correct network interface names

5. Install conjure-up using snappy:

$ sudo snap install conjure-up

6. Then you will be able to deploy OpenStack NovaLX using conjure-up:

$ conjure-up

I also put the instructions here: http://www.dangtrinh.com/2017/09/how-to-deploy-openstack-in-single.html

Hope that will help.

  • Hi. I tried everything till step 6 on dangtrinh.com/2017/09/how-to-deploy-openstack-in-single.html but I get the same error again ! This time i even get the additional error that I need to disable my bridge lxdbr0 using some command , tried that command but still same error when I run conjure up :( Note: I havent reinstalled ubuntu as I have some important things running on it – Abbas Oct 3 '17 at 11:02
  • sudo lxc storage list shows the name of the zfs pool and its path but when I run /snap/bin/lxc storage list nothing shows up. – Abbas Oct 3 '17 at 11:06
  • Update: I launched a container called container1 (sudo lxc launch ubuntu:16.04 container1) and then ran conjure-up . Now I get a different error which says LXD not found, please install lxd and gives me some commands : sudo snap install lxd /snap/bin/lxd init --auto /snap/bin/lxc network create lxdbr1 ipv4.address=auto ipv4.nat=true ipv6.address=none ipv6.nat=false . I run all of these but the error still exists ! – Abbas Oct 4 '17 at 6:21
  • Hey, try to remove lxd from snaps and re-install it from its latest ppa. – Trinh Nguyen Oct 4 '17 at 12:23
  • Thanks I was able to deploy openstack on a VirtualMachine with ubuntu 16.04LTS Server with those steps. My host machine is also Ubuntu 16.04LTS Desktop Version. So what should i modify in step no. 9 to access the open stack dashboard from the host machine ? – Abbas Oct 9 '17 at 8:22

I have the same problem with a fresh install of Ubunutu Server 17.04. I'm following this guide https://www.ubuntu.com/download/cloud/try-openstack but it seems LXD needs to be configured exactly right before starting. I've tried several resources online but keep striking out. It would seem like there would be really solid instructions somewhere for getting s simple environment up and running from a clean install. Searching all night but nothing yet...

  • at the same state...if we run them at the wrong order it is an issue – Rıfat Erdem Sahin Nov 17 at 16:41

This worked for me on fresh 16.04 install:

sudo apt-get update; sudo apt-get upgrade -y; sudo snap install lxd; sudo snap install conjure-up --classic; /snap/bin/lxd init --auto; /snap/bin/lxc network create lxbr0 ipv4.address=auto ipv4.nat=true ipv6.address=none ipv6.nat=false

After its just

conjure-up or conjure-up openstack

And you can install Openstack with NovaLXD.

Once you copy/paste, go ahead and make yourself tea or coffee as it will take a while to download and install all packages and updates. There was also suggestion to reboot your box after.

(A reboot is required to replace the running dbus-daemon.Please reboot the system when convenient. Processing triggers for ureadahead (0.100.0-19) ureadahead will be reprofiled on next reboot)

You might also create your ssh key right after install or before:

ssh-keygen

And follow instructions on the terminal.

Enjoy!

  • After /snap/bin/lxd init --auto I get cat: /proc/self/attr/current: Permission denied /snap/lxd/6492/commands/lxd: 6: exec: aa-exec: Permission denied – Peter Apr 5 at 15:46

You need to make sure you've sudo snap install lxd as the snap is now required. We are currently updating the documentation to reflect this along with additional configuration steps.

  • Nope, lxd installed by snaps in Ubuntu 16.04 messes everything up. I had to remove lxd installed by snaps. – Trinh Nguyen Oct 9 '17 at 8:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.