12

I have a .bash_aliases file with several aliases which I use to connect to Windows machines. The aliases are set up like this:

rdesktop -d domain -u username -p password -k fr-be -g 1920x1024 -T Customer-SupportPC -a 24 IP

Yesterday the connection was working fine, today the connection gives me following error:

ERROR: Failed to open display:

SSH sessions are no problem, it's only a problem with rdesktop to a Windows server. X11 forwarding is set to yes in /etc/ssh/sshd_config

| improve this question | | | | |
  • Have you tried to set display DISPLAY=:0.0 rdesktop <server>? Your didn't change something? How was your last time connection? How you terminate your session? Does any rdesktop is still running? if yes, you would need to kill those sessions first as it caused the DISPLAY used by that session still and doesn't allocate same display thought – αғsнιη Sep 17 '17 at 15:39
  • @αғsнιη I have set DISPLAY to 0 but not for a specific server, makes no difference except it shows display:0 in the error. No, I did not change something. What do you mean by last time connection? I usually terminate my session by closing the rdesktop screen but when I get this error I use ctrl + c. There are no rdesktop procs in ps -ef – Noosrep Sep 18 '17 at 6:54
  • Are you in GNU screen or tmux? Do you get the same error when you run xclock? – Adam Katz Oct 26 '17 at 19:54
  • 1
    AFAIK you need to export the DISPLAY variable, not set it. Otherwise child processes, like your rdesktop, won't inherit it. – Robert Riedl Jan 27 '18 at 14:44
0

I have never had any luck with the rdesktop program. I have great luck with the remmina package. If you don't mind, I suggest you try that and see if it solves this.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.