0

FYI I'm new to Ubuntu. I can't get sound through my monitor that is connected via HDMI-cable to the graphics card. On my laptop(Win10) it works lika a charm. I've built a PC:

  • Motherboard: Gigabyte A320 GA-A320-DS2
  • CPU: AMD RYZEN 5 1600
  • Monitor: HP24es
  • Ubuntu: 16.4.03 LTS
  • AMD driver: amdgpu-pro 17.30-465504

In system settings/audio HDMI doesn't show up as an output-option, only S/PDIF. I've tried pulseaudio but it shows all the HDMI output options as unplugged. GNOME ALSA Mixer has everything unmuted under the Realtek ALC887-vd tab and the ATI R6xx HDMI tab shows no options whatsoever. aplay -l shows:

aplay -l

**** List of PLAYBACK Hardware Devices ****

card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 0/1
Subdevice #0: subdevice #0

card 0: HDMI [HDA ATI HDMI], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0

card 0: HDMI [HDA ATI HDMI], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0

card 0: HDMI [HDA ATI HDMI], device 9: HDMI 3 [HDMI 3]
Subdevices: 1/1
Subdevice #0: subdevice #0

card 0: HDMI [HDA ATI HDMI], device 10: HDMI 4 [HDMI 4]
Subdevices: 1/1
Subdevice #0: subdevice #0

card 1: Generic [HD-Audio Generic], device 0: ALC887-VD Analog [ALC887-VD    Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0

card 1: Generic [HD-Audio Generic], device 1: ALC887-VD Digital [ALC887-VD    Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

I've tried this Ubuntu refuses to output audio via HDMI, this https://itsfoss.com/how-to-fix-no-sound-through-hdmi-in-external-monitor-in-ubuntu/ and this:

pacmd set-card-profile 0 output:hdmi-stereo

but so far nothing has worked. Any ideas?

  • No idea if that was fixed in the meantime but there used to be a Grub setting to be made for HDMI sound on Radeon driver: askubuntu.com/questions/67113/… – Takkat Sep 13 '17 at 13:59
  • Sorry. Double posted this in the forum you suggested. Thank you! Did not solve the problem though. Made the changes, updated and rebooted. HDMI sound is still not an option as audio output and still shows up as unplugged in PulseAudio. Got this error message during suggested changes: ** (gedit:2464): WARNING **: Set document metadata failed: Setting attribute metadata::gedit-position not supported I don't know what that means but after a reboot the line in /etc/default/grub is changed to: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1" – Erik Myrsell Sep 13 '17 at 18:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.