3

I have an AlienWare 15 R3. I made a Ubuntu installation media using Universal USB installer. For some reason I can't get the option to install Ubuntu/Kubuntu in UEFI mode in boot list although legacy option is available .

I have windows installed in UEFI and want Linux to work in UEFI side by side.

Here is what I have tried so far.

  1. Disabling secure boot.
  2. Switching partition type of media from NTFS to FAT32
  3. Disable and Enable Legacy Support when bios is on UEFI mode.

Anyone have any idea how to fix this?

  • is he USB booting in EFI mode? the computer has to boot in EFI mode in order to install in EFI mode. – ravery Sep 13 '17 at 4:04
  • My computer boots windows in UEFI mode. – Sam Thomas Sep 13 '17 at 4:10
  • And I am using USB as an installation media it doesn't have UEFI as an option for booting linux installation media but it does have legacy as an option. – Sam Thomas Sep 13 '17 at 4:10
  • get the image that supports EFI boot ... (64-bit). the computer has to boot EFI to install in EFI mode. you can not install EFI from a legacy boot – ravery Sep 13 '17 at 4:12
  • 1
    There is no such "UEFI option" in the grub menu. By the time grub displays, the choice has already been made, depending upon the UEFI settings on your machine, and how the install media boots is how it installs. If you are talking of an EFI menu, then you have to find the UEFI settings to allow a UEFI boot, maybe setting an admin password will provide additional options, maybe settings trust on the bootloaders, etc. – ubfan1 Sep 13 '17 at 4:48
1

To boot in EFI mode, an external boot medium needs to have an EFI-mode boot loader (EFI/BOOT/bootx64.efi) on a filesystem that the firmware can read. The symptoms you describe are consistent with this not being the case. Two causes are common:

  • No EFI boot files -- Some programs for creating bootable USB media from Ubuntu's .iso files omit the EFI-mode boot loader entirely, or put the EFI boot loader in a non-standard location. This is true of Pen Drive Linux (aka YUMI and one or two other names), for instance. Others require that particular options be set before they'll create EFI-bootable media. See my notes on a few programs for more details.
  • Quirky incompatibilities -- Sometimes a boot medium works fine on one computer but not on another. This can be because there's something odd about the boot medium that's fine with some computers but not with others or because of a bug in the firmware.

In both cases, the solution usually involves creating the boot medium with another tool, although sometimes adjusting options in the tool you're using may do the trick. As you mentioned NTFS and FAT, be aware that all EFIs support FAT boot media, but I have yet to encounter one that supports NTFS. (I've seen a small number of posts that claim NTFS support in particular computers, but I have yet to see evidence backing up these claims.) Thus, you should stick with FAT, if the tool gives you an option. (Furthermore, FAT32 is more reliable on some older computers than is FAT16 or FAT12, so using FAT32 may be helpful.)

Based on my own experience and online reports, Rufus is one of the more reliable and flexible tools for this task, but the last I checked it was Windows-only. In Ubuntu, dd seems to be pretty reliable, although some computers dislike the Frankenstein's Monster format that a dd copy of the .iso file to a USB flash drive creates, so in some cases you may need to use something else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.