2

I got some issues when running my Windows VM on Ubuntu 16.04 LTS, it seems that the VM is taking all the memory and CPUs and the system was slowed down really bad.

My Current System is,
Ubuntu 16.04 LTS Memory: 15.6 GiB Processor i7-5600U @ 2.6GHz x 4
My VM system is,
Windows 8.1 Pro Installed Memory: 8.00 GB System type : 64-bit
When running the VM, my system performance looks like the following graph,
enter image description here

And the configuration of my VM is, enter image description here

My machine runs really slow and the fan is much noisy than normal. By the way, my Windows is idling without running any program.

Does anyone have the similar issue?

Thank you in advance.

  • Whether the Virtualization is enabled within the BIOS? – pa4080 Sep 12 '17 at 20:39
  • 1
    @pa4080 I updated my post, and I think the Virtualization is enabled. – HaipengSu Sep 12 '17 at 20:52
  • @pa4080 yes. it is enabled for sure. – HaipengSu Sep 12 '17 at 21:03
  • 2
    In the guest OS settings, set the memory to 2048 and the CPU's = 2. Report back. – heynnema Sep 13 '17 at 0:30
  • @heynnema, you made a good point. I changed to 2CPUs and 4G, the performance for the Host OS is better. But the windows VM is much slower. I mean 4G 2CPU should be running well right? – HaipengSu Sep 13 '17 at 12:45
1

From the comments...

In the guest OS settings, by setting CPU=4 you've committed all of the CPU resources in your computer to the guest VM. Host operation will slow to a crawl. Generally speaking, you shouldn't commit more than half of the number of physical CPUs to a guest VM.

In the guest OS System settings, set the memory to 2048 and the CPU's = 2.

enter image description here

enter image description here

| improve this answer | |
  • 1
    Have you considered expanding on this to explain how these settings are changed or perhaps referring to an answer that does? – Elder Geek Sep 13 '17 at 15:48
  • 2GB is too slow for me. I will stick to 4G now, my main system is running better when setting 2 CPUs for the VM. I will accept your answer later in case someone has a similar symptom with a better solution. Thank you. – HaipengSu Sep 13 '17 at 17:30
  • I think the CPUs configuration matters. Thank you so much. – HaipengSu Sep 14 '17 at 17:24
  • @HaipengSu glad it's working for you now. Thanks for the update! – heynnema Sep 14 '17 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.