5

elementary OS 0.4 "Loki" debuted an interesting new feature: AppCenter, a 'pay what you want' app store. It features many well designed Indie apps.

elementary OS AppCenter

I'd like to try this new AppCenter and the apps it offers. Is there an easy way to get the AppCenter on Ubuntu?

4

If you're on Ubuntu 16.04 LTS you can install AppCenter from elementary OS PPA.

Step 1: Add the PPA

sudo add-apt-repository ppa:elementary-os/stable
sudo apt update

Step 1.1: For releases newer than 16.04LTS

If you're on an Ubuntu release newer than 16.04 LTS, use the following Daily PPA instead:

(I have had success with daily on 16.04 as well)

sudo add-apt-repository ppa:elementary-os/daily
sudo apt update

Step 2: Add elementary Apps repo

AppCenter is supposed to add this repository automatically, but that may not always happen. Add the repo and it's key:

sudo bash -c 'echo "deb http://packages.elementary.io/appcenter $(lsb_release -sc) main" >> /etc/apt/sources.list.d/appcenter.list'
sudo wget -O /etc/apt/trusted.gpg.d/appcenter.asc http://packages.elementary.io/key.asc
sudo apt update

Step 3: Install AppCenter

Then all you have to do is install the appcenter package:

sudo apt install appcenter

If the installation fails due to unmet dependencies on 16.04 LTS, add this PPA for PackageKit

sudo add-apt-repository ppa:ximion/packagekit
sudo apt update

and try again to install. When it's installed successfully, the launcher for AppCenter should show up in App Dash.

App Center in Dash

Or you can just launch it from the terminal as:

appcenter

Or:

io.elementary.appcenter
  • Thanx 4 the answer!😃 However, I thought the elementary OS PPA isn't supposed to be added to vanilla Ubuntu. It holds a lot of packages, some of which can possibly break Ubuntu. Besides, the PPA packages target Ubuntu 16.04LTS (elementary OS being LTS based). So, not sure if it'll work easily on intermediate Ubuntu releases. Anyway, I'll definitely test your method and let you know the results. 😊 – HEXcube Sep 14 '17 at 18:42
  • I tested on the latest 17.10 daily and it it worked!😊 I just had an extra step of manually changing the PPA release from artful to xenial (coz elementary OS packages target Ubuntu 16.04LTS Xenial base). Surprisingly the PPA didn't break any Ubuntu packages. However, the appcenter wouldn't install on Ubuntu 16.04LTS due to missing dependencies. That seems to be strange considering elementary OS is 16.04LTS based. Anyway, I think I'll figure it out, eventually... – HEXcube Sep 16 '17 at 18:50
  • @HEXcube Yeah, that is strange. I have it installed on two different 16.04 hosts here and they both seem to be working fine. I do, however, really like the Appcenter. Pretty nice and neatly laid out. :) – Terrance Sep 16 '17 at 22:37
  • "there are other non-EoL Ubuntu releases, like Ubuntu 14.04 LTS" @EliahKagan Oops! I didn't think about 14.04LTS. But since AppCenter is available only for 16.04LTS and up, I think it's better to mark that in the answer. – HEXcube Sep 17 '17 at 6:43
  • "you'll have to change the apt sources to point to xenial is pretty vague" @EliahKagan I'll link to another answer showing how to do that. – HEXcube Sep 17 '17 at 6:45

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.