I installed Ubuntu 11.10 - 32bit (with 40GB disk space) alongside windows7. Then, I installed a Ubuntu 11.10 - 64bit alongside windows, as the 32bit was installed by my mistake. I chose the recommended option of saving the files by upgrading Ubuntu but this procedure failed. When I tried to reboot, the system refused to reboot. Doing a clean install of 64bit ubuntu solved the problem.

Now, everything is good and Ubuntu 64bit is installed alongside windows except that I seem to have lost some disk space. Looking at the disk utility, I see that there are 2 swap partitions:



Going by the number, do you think, I can choose delete partition from the disk utility on sda5 ? Will I be able to recover the 4.2GB space and get it to be counted into the 32GB space (sda6) where this Ubuntu is running ?

Kindly help on how to go about this, I am a newbie and I am a bit worried if i will mess up something.

Note: As a new user couldn't attached the screenshot of the disk utility


You shouldn't have any issue deleting the second swap partition (sda5 for you). Actually you can run Linux without a swap partition and even hibernate without one.

Once it's done, you need to edit your /etc/fstab file so that the swap line actually points to the swap partition that is left (sda7 in your case).

If you want to regain the unallocated space you'll need to boot a live cd/usb and expand one of your partition with GParted.


Run from terminal in your preferred Os sudo fdisk -l | grep swap and remove from /etc/fstab the one that swap partition that does not match, if there is such a partition listed in fstab.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.