0

I wanted to be able to do the twofinger scrolling and found out that purging synaptics and leaving libinput allowed me to do that. After that I noticed that the tap-to-click functionality wasn't working. I enabled it adding: Option "Tapping" "on"

that got it working again but disabled twofinger scrolling. Does enabling one feature disables the other? If not, how can I enable both using libinput?

Section "InputClass"
    Identifier "libinput touchpad catchall"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    Driver "libinput"
    Option "Tapping" "on"
    Option "NaturalScrolling" "true"
    Option "ScrollMethod" "twofinger"
EndSection

2 Answers 2

2

Accroding to archlinux manual, your lines should look like this:

/etc/X11/xorg.conf.d/30-touchpad.conf ...

 Section "InputClass"
 Identifier "devname"
 Driver "libinput"
 MatchIsTouchpad "on"
 Option "Tapping" "on" 
 Option "ClickMethod" "clickfinger"
 Option "NaturalScrolling" "true"

...
EndSection

Bear in mind that some of them may only apply to certain devices.

Source: https://wiki.archlinux.org/index.php/Libinput

2
  • thank you, but I'm not really worried if it's natural scrolling or not. what I'm looking for is a way to enable both two finger scrolling and tap-to-click through libinput! Sep 12, 2017 at 23:40
  • I edited the answer to suit libinput. This is the way to do it as written in documentation of archlinux. If both still do not work, your hardware doesn't support both at one time im afraid.
    – chazecka
    Sep 13, 2017 at 6:25
0

I believe it should be Option "Tapping" "true", not "on"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.