0

I installed PDFXChange Viewer, when I open a pdf file in the viewer, the bookmarks (i.e. outlines) which are in Chinese (shown on the left panel) are not shown correctly but as squares. How can i make them show correctly?

The Chinese characters in bookmarks used to be shown correctly in the viewer, before I reinstall Ubuntu from 14.04 to 16.04, and Wine from 1.6 to 2.0. Are Ubuntu and Wine the reason?

Thanks.

enter image description here

  • I'm almost sure the problem is related to Wine. Did you saw this or this other? – Redbob Sep 12 '17 at 18:16
  • @Redbob Thanks. By the first link, "LC_ALL=zh_CN wine /home/t/program_files/PDFXCview.exe *.pdf` still doesn't solve the problem. By the second link, I am not sure how and where to install chinese fonts. – Tim Sep 12 '17 at 18:22
  • According to Windows structure, fonts are located at %windir%\fonts. look this about installing fonts in Wine – Redbob Sep 12 '17 at 18:29
  • Thanks. Where can I get chinese fonts and how shall I install chinese fonts? Note that the PDFXChange viewer can show chinese fonts in the main text panel, but not in the bookmark panel, so it is not that chinese fonts are not entirely working under Wine. – Tim Sep 12 '17 at 18:32
  • Open this PDF file with another tool (notepad at wine, for example) to certify it's text-based or image-based file. Could you send a link of this document or another one? – Redbob Sep 12 '17 at 19:09
1

After doing a simulation of your problem, I came to the conclusion this issue is related to limitations of this tool (PDF-XChange Viewer). Such version doesn't have additional language support.

The document you attached has embedded fonts. So we could see them, even if it had not been installed.

So, you should install PDF-XChange Editor, this version offers full-languague support, among other features.

After that, to grant your interface will be well established, install:

Below you can see the final result of my simulation:

enter image description here

  • Thanks. (1) Chinese fonts in bookmarks in PDFXChange Viewer worked fine under Ubuntu 14.04 and wine 1.6, so I am not sure if it is the problem of the viewer. (2) typewriter doesn't work in PDFXChange Editor tracker-software.com/forum3/viewtopic.php?f=62&t=29282 – Tim Sep 13 '17 at 13:30
  • Sure that is viewer problem. I'm running Lubuntu 17.04 and Wine 1.8.7. Please gently mark a tick below down arrow to accept this answer as better. The second point is another issue that Tracker Support is dealing with. Thanks – Redbob Sep 13 '17 at 13:51
0

End to any japanese fonts (and japanese games) problems by running my script:

#! /bin/sh

#Root needed
clear
if [ "$(whoami)" != "root" ];
then echo "You must be root to be able to continue"
exit
fi
#Checks if already installed
clear
FILES="/var/lib/locales/supported.d/ja"
echo "Japanese on WINE:"
for file in $FILES
do if [ ! -e "$file" ]
then echo "Starting..."
sudo touch /var/lib/locales/supported.d/ja; 
sudo echo "ja_JP.UTF-8 UTF-8" >/var/lib/locales/supported.d/ja;
sudo echo "ja_JP.EUC-JP EUC-JP" >>/var/lib/locales/supported.d/ja;
sudo dpkg-reconfigure locales -u;
sudo touch /usr/bin/wine-jp
sudo echo "LC_ALL=ja_JP.UTF-8 wine ~/.wine/drive_c/windows/system32/explorer.exe C:" >/usr/bin/wine-jp;
sudo chmod +x /usr/bin/wine-jp;
echo 'Done, Now type "wine-jp" to test it'
else echo "Is already supported"
fi
done
return 0

After that you can use my second script as a optional choice if you prefer but the first script must be executed:

#! /bin/sh

cd ~/.wine/drive_c && LC_ALL=ja_JP.UTF-8 wine "$(zenity --file-selection --file-filter=""*.exe" "*.EXE" "*.msi" "*.MSI"" 2> /dev/null)"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.