0

I am using ubuntu 16.04 and it has rtl8723be driver and does not shows wifi. I have tried all the methods stated in these 1, 2 . Also installled new drivers from https://github.com/lwfinger/rtlwifi_new.git. Any leads would be helpful.

output of lspci -knn | grep Net -A3; rfkill list

03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
    DeviceName: Sanji2 
    Subsystem: Hewlett-Packard Company RTL8723BE PCIe Wireless Network Adapter [103c:81c1]
    Kernel driver in use: rtl8723be
    Kernel modules: rtl8723be
0: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
  • Please edit your question and add output of lspci -knn | grep Net -A3; rfkill list terminal command. – Pilot6 Sep 12 '17 at 16:37
  • updated @Pilot6 – 4rshdeep Sep 12 '17 at 16:58
  • It looks OK. What is the kernel uname -a? And what do you mean by "does not shows wifi"? – Pilot6 Sep 12 '17 at 17:36
  • Except of the sources of my answer I just found this: askubuntu.com/questions/883673/rtl8723be-wifi-incredibly-weak... It is somehow the same but try my answer first because all steps needed. – koleygr Sep 12 '17 at 17:50
0

First attempt:

Try the commands with your installed version:

echo "options rtl8723be ant_sel=1" | sudo tee -a /etc/modprobe.d/rtl8723be.conf
sudo modprobe -rf rtl8723be
sudo modprobe -v rtl8723be

Check if you can find wifi.

If you do... just restart and it is ready.

Before go to the second attempt, try with option ant_sel=2 (and again all three commands)

Second attempt:

Go to the source folder of the package installed and uninstall it by running the command

sudo make uninstall

Then run:

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install rtlwifi-new-dkms

(I think it is the same package you already installed but it works for my 16.04 and it will accept updates too)

Again all the commands of the first attempt:

echo "options rtl8723be ant_sel=1" | sudo tee -a /etc/modprobe.d/rtl8723be.conf
sudo modprobe -rf rtl8723be
sudo modprobe -v rtl8723be

You should find wifi after the last command.

If not try ant_sel=2 on above options and give all the (3) commands

If it is better:

Restart and ready.

Sources (combination):

https://kharisecario.wordpress.com/2017/03/16/installing-realtek-rtl8723be-wifi-driver-for-debian/

https://ubuntuforums.org/showthread.php?t=2364060&highlight=rtl8723be

https://ubuntuforums.org/showthread.php?t=2363051&highlight=rtl8723be

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.