1

I have a US layout on my keyboard, but since I'm from Finland sometimes I have to use letters ä and ö. On Windows it was easy, just change the keyboard layout with super+space shortcut. A few weeks ago I switched to Ubuntu and on GNOME I had no problem, but now that I'm trying out Xfce it doesn't work.

When I go to Settings and set Finnish to second keyboard layout and shortcut to super+space, it changes it like it should. However after changing to Finnish, caps lock is always on.

I have added this to Xmodmap:

! CapsLock -> Mode_switch
keycode 66 = Mode_switch

keycode 44 = j J Down
keycode 45 = k K Up
keycode 43 = h H Left
keycode 46 = l L Right

So I can use hjkl as arrow keys. But because caps is always on when I'm using fin layout, I can't use those keys at all. This also prevents me from changing back to the US layout with super+space.

How can I fix this? My keyboard is Magiforce with 68-key layout, but in settings I have "Generic 105-key (Intl) Pc" as model because there isn't a 68-key model option. Works fine when using US layout but not when using Fin layout.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.