I am wondering if there is a way to fix the following problem with Intel HD 3000 video drivers on Oneiric. As can be seen from the the linked image below the problem is that in some games (namely Aquaria and Myth II Soulblighter native client) all 2D textures inside OpenGL (3D) have visible edges around them, making typically bunch of rectangles that should not be seen otherwise (or are not seen on other video cards). this is the case apparently with all textures, both those that should be transparent (e.g. have something only in the middle but nothing around the edges) and non-transparent. I am wondering if this is a bug, or a setting issue that I can somehow fix.

Since only some apps are affected by this, mainly an indie game (Aquaria) and an older game (Myth II), I am wondering if they use some older and possibly less common OpenGL function for displaying 2D textures inside 3D (OpenGL) context and for which current Intel driver simply does not do proper texture aliasing around the edges of the texture, resulting in the said lines...



P.S. Forgot to mention, this is on a new HP dm1-4050 which I is a sandy bridge chipset with an integrated Intel HD 3000 inside it. The system is running Oneiric with latest updates including the latest ppa intel xorg driver (but not including any new changes to Xorg or mesa). The problem is apparent in 2 3D games, Aquaria and Myth II Soulblighter, both of which are using 32-bit libs (they are 32-bit games) on a 64-bit system.

UPDATE: After corresponding with the Aquaria developer, he suggested there might be a problem with 32-bit builds of the libGL* libs for the 64-bit system (which is what I am using), since both games are 32-bit apps, and so far they are the only ones to exhibit this problem... I am waiting for the Aquaria dev to supply a test release for the 64-bit systems to see if the problem will go away and if it does then, this is definitely the problem with 32-bit builds of supporting libs. If so, how could I proceed to fix this?

UPDATE 2: I just tested the 64-bit version of Aquaria and the artifacts are gone, so this is definitely problem with ia32-libs and how they provide mesa/GL libs (I am not sure whether it is an issue of version or the way they are built or something entirely different). I informed the upstream maintainers of ia32-libs but have no idea where the problem lies...

UPDATE 3: I tried Ubuntu 32-bit via live CD and the same problem persists suggesting that on any version of OS 32-bit mesa GL/GLU libs + Intel HD 3000 combo exhibit this problem but the same is absent on a 64-bit version...

What would be really helpful is if others who run 32-bit version of the OS and use Intel HD 3000 video card could please test the Myth II demo downloadable from the following link: tain.totalcodex.net/items/show/myth-ii-demo-linux and report whether they have any issues as well as what chipset they are using (e.g Sandy Bridge is the one my laptop uses).

As a pointer, here's the .h file from Aquaria with all OpenGL calls that might shed light as to where the problem might lie:

hg.icculus.org/icculus/aquaria/file/tip/BBGE/OpenGLStubs.h (my reputation limit disallows use of more than 2 links, so this one has to be entered manually into the browser)

  • It would be nice to hear from other sandy bridge/intel hd 3000 users whether they have the same problem as that would help identify whether this is an issue with my particular setup or is a more widespready sandy bridge/intel driver issue... Jan 16 '12 at 4:25

Sandy Bridge support has improved throughout 2011, even after the release of Oneiric. You could try using bleeding-edge packages from the xorg-edgers PPA to see if your problems have been fixed there. To do this, run the following commands in a terminal:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update && sudo apt-get upgrade

After rebooting your system should be using the newest drivers, X.org and kernel.

If you want to revert to the original versions of all the updated packages run:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:xorg-edgers/ppa
  • Tried latest version and that did not fix it. There are also problem with ppa builds of libGLU apparently since it has no 32-bit builds inside it (I am running 64-bit version of Oneiric but also want to run some 32-bit apps). Jan 15 '12 at 0:14
  • Perhaps xorg-edgers is too aggressive an update. There's this other PPA (ppa:glasen/intel-driver) which doesn't force mesa 8 and linux 3.2 onto your system but still offers intel 2.17. No promises, though - I think an important part of the relevant code changes are in mesa and the kernel - but a driver update is still a driver update..
    – pablomme
    Jan 15 '12 at 3:39
  • Ok, tried that PPA and this one seems to keep all the symlinks necessary for 32-bit apps but still no change in respect to this issue. I am adding another screenshot to further clarify the issue. Please see below... imageshack.us/photo/my-images/341/mythintel3000rectangles.jpg Please note that the rectangles do not denote those units being selected (those are green rectangles). These match the texture's edges. You can also see objects on the floor have those as well... Jan 15 '12 at 15:36

The problem has been fixed as of approx. a month ago using proposed repository for 11.10 which also includes a recently released upstream fix for this particular issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.