2

I'm trying to format a MicroSD where I've write Retropie. I'm using an adapter.

I've tried fdisk, gparted, the disk manager and the command shred in Lubuntu.

In Window$ I've tried SD Card Formatter.

All the processes go away and complete without errors but at the end nothing changed.

What should I do?

EDIT: I've tried everything, I think it's grid-locked

  • It might be hardware issue with this specific SD card, what happened when you tried running the same tools on another SD card? – Yaron Sep 12 '17 at 8:19
  • Everything works fine with other microsd. But this microsd work good in the RPi – zar Sep 12 '17 at 8:26
  • Have you tried according to the tips in the link in my answer? In that case, yes, I'm afraid that the card is 'grid-locked'. Memory cards have a limited lifetime (expected number of writes of the memory cells), but also concerning 'choking' because too few good memory cells are available, In the future you can try a method that I use for cards and pendrives: Wipe the whole drive, when writing speed is reduced to half the original speed (not too often). This will make good memory cells available to be used, ubuntuforums.org/… – sudodus Sep 12 '17 at 13:15
0

Personally, I would wipe the disk first and then format it.

To wipe a disk I would use the command

sudo dd if=/dev/zero of=/dev/sdX* bs=1M status=progress

*replace sdX with the target drive location. To get a list of drives and their partitions run lsblk. Ensure that you list just the drive code eg mmblk0/sda and not a partition on that device eg mmblk0p1/sda1

This will overwrite every bit on the disk with 0s however it may take some time. But at the end, there will be nothing on it.

Once the drive has been wiped you should be able to format it as you wish. I would generally use the mkfs command as suggested in Lorenzo's answer. However, if I were to use a graphical tool I would recommend gparted

The 'if' is the part to be copied to the disk and the 'of' is the location to which it is to be written to, the status part means that it will show the progress of the operation as it goes along.

| improve this answer | |
0

I suspect that the SD card is damaged, maybe in a read-only state called 'grid-locked'. It is a first stage of failing. But there are things to check before you give up on the card.

You can continue testing/checking it according to the following link,

Can't format my usb drive. I have already tried with mkdosfs and gparted - Analysis of the problem

| improve this answer | |
0

First run lsblk. Then enter your SD card and run the same command again: the difference between the two outputs will represent your /dev/sdx device.

Once you have recognised the device, run

mkfs -t <type> /dev/sdx

where type can be vfat, ext2, ext3, ext4.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.