I created a new account(administrator) and delete the first account .

In this new account , The partitions are access denied . Some error like these are occur : "You are not owner" "You don't have necessary permission to access "Software"."

I updated my ubuntu , two win7 and one winXP , can any one help me to solve it without risk ?

Thanks .


The previous account is probably the owner of the files in the partition. If the partitions are ext (Linux) you only need to go to a terminal and replace the owner of the files (as you deleted the 1st user, you don't need to access the files with it anymore).

sudo chown -R new_user_name /the_place_you_mounted_the_partition

-R is to apply the command to all subdirectories, you can check chown command with man chown

After you can check if it worked using ls -l /the_place_you_mounted_the_partition

If you have more users to share the partitions, after that you can create a group, assign the group to the files and place the users that need access in the group.


In /etc/fstab:

#Entry for swap partition :
UUID=dff20e79-bdef-4615-b582-6790c45d37a1       none    swap    sw      0       0

with UUID = swap partition UUID

NTFS partitions:

in /etc/fstab:

#Entry for /dev/sda6 (NTFS partition) :
UUID=01F49D053D1E38F0   /mnt/dados      ntfs-3g defaults,suid,dev,exec,locale=pt_BR.utf8        0       0

locale= is only if you need special locale config, you can discard it if English.

| improve this answer | |
  • swap is used by root I think and you don't need access to it. NTFS should be owned by root:root and chmoded to 777 (drwxrwxrwx) and you'll have access. Linux permissions do not apply to NTFS partitions. Will update answer on how to mount swap. – laurent Jan 15 '12 at 17:20
  • I can't do that . because of this error during save fstab file:"you don't have necessary permissions". – mohammads Jan 16 '12 at 7:55
  • you need to edit fstab with sudo (sudo nano /etc/fstab) to be able to save the changes – laurent Jan 16 '12 at 15:49
  • Thank you , but now , after boot Ubuntu , a blue screen appears instead Login screen . I tried very much to fix it , but at last I had to completely delete it and start my project on Win7 . "The problem doesn't solved". Try to solve it for others . Thanks again for your attention . – mohammads Jan 18 '12 at 10:11
  • The original problem, ownership (and mounting) has been solved and I don't think the blue screen came from that because ubuntu was booting after changing ownership of its partition. Maybe for the other partitions you changed something wrong in fstab, used a wrong UUID, mixed the UUID or mounted in bad or inexistent places. Anyways this is the only file changed and you could repair it with a Live CD instead of wiping the partition if this was the problem. – laurent Jan 18 '12 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.