2

I'm just trying to install Meld 3.x. It has some dependencies and one of them is GTK+ >= 3.14. I am fed up of not able to update to GTK+ 3.14.

I want to know how to install meld latest version which is supported by GTK+ 3.12.

Is there a straight-forward way to install GTK+ 3.12 or Meld on my Ubuntu PC? Please include a step by step process.

PS: I did try installing Meld using Aptitude and Software center. It installs outdated versions. I need the latest version.

3
  • I doubt it. Even the GNOME3 PPAs don't have anything above 3.12 for 14.04
    – muru
    Sep 12 '17 at 6:45
  • 1
    Is there any reason to not upgrade Ubuntu to the version 16.04? Then you’ll get libgtk-3-0 version 3.18.9 which should allow you to build the most recent Meld yourself.
    – Melebius
    Sep 12 '17 at 6:51
  • Ok I think I'll just edit the question for 3.12 compatible meld
    – Abhi
    Sep 12 '17 at 8:16
2

There is a PPA which includes Meld 3.18 for Ubuntu 14.04: ~jonathonf/backports. However, it also includes backports of a large number of other packages. I haven't tested this PPA, so maybe you should only install meld from it (see How do I cherry pick packages from a PPA?) and see if it works.

There's also another PPA which has Meld 3.14: ~pachulo/meld-backports.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.