1

Hello Ubuntu community,

My WiFi connection is not working.

Bellow Wifi connections bar it reads "device not ready".

I'm on Ubuntu 16.04.3 LTS

Greetings!

Ortiz


Additional details:

description: Ethernet interface

product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

vendor: Realtek Semiconductor Co., Ltd.

physical id: 0

bus info: pci@0000:07:00.0

logical name: enp7s0

version: 06

serial: b8:70:f4:b8:31:14

size: 1Gbit/s

capacity: 1Gbit/s

width: 64 bits


I also tried to install the driver provided by Realtek availeable here:

http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=5&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false#2

(LINUX driver for kernel up to 4.7)

./autorun.sh

Check old driver and unload it.

rmmod r8169

rmmod: ERROR: ../libkmod/libkmod-module.c:793 kmod_module_remove_module()

could not remove 'r8169': Operation not permitted

rmmod: ERROR: could not remove module r8169: Operation not permitted

Build the module and install

arch/x86/Makefile:140: CONFIG_X86_X32 enabled but no binutils support

make[2]: *** No rule to make target 'WiFi/r8168-8.044.02/src'. Stop.

make[1]: *** [clean] Error 2

make: *** [clean] Error 2


What should I do?

  • do aptitude update && aptitude upgrade -y this might help to re-install dependencies necessary to enable your wifi adapter. – Prince Adeyemi Sep 11 '17 at 2:28
  • Hi LasVegasCoder! Thank you for your input. I tryed to run the command you suggested and got the following error: E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied) E: Unable to lock the administration directory (/var/lib/dpkg/), are you root? Which is strange, since I added "sudo" to it. – chicOrtiz Sep 11 '17 at 2:41
  • Full log: sudo aptitude update && aptitude upgrade -y Hit br.archive.ubuntu.com/ubuntu xenial InRelease Hit br.archive.ubuntu.com/ubuntu xenial-updates InRelease Hit br.archive.ubuntu.com/ubuntu xenial-backports InRelease Get: 1 security.ubuntu.com/ubuntu xenial-security InRelease [102 kB] Fetched 102 kB in 1s (84,9 kB/s) E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied) E: Unable to lock the administration directory (/var/lib/dpkg/), are you root? – chicOrtiz Sep 11 '17 at 2:49
  • 1
    do sudo aptitude safe-upgrade -y it will ask for your password to install update, that's normal – Prince Adeyemi Sep 11 '17 at 3:03
  • do: ps aux | grep apt you will see a pid# then kill the process with: kill -9 processID or just kill processID then do sudo aptitude safe-uprade -i – Prince Adeyemi Sep 11 '17 at 3:08
0

Ubuntu 16.04 WiFi not working solved

do the following:

sudo aptitude safe-upgrade -y

The above command re-install updated version and necessary dependencies on your Linux box.

NOTE: It may take a minute or more based on your last updates.

You may need to reboot your system to fully recognize the new updates.

Check your WiFi

ifconfig or iwlist are your friends.

Remember when in doubt, do: man doubt e.g man ifconfig

Hope this helps

-1

This is a sketch for the answer. Maybe part of the procedure is unnecessary.

0) Fill your user's password when asked.

1) Update your system using the software updater and a wired connection.

2) Use the command "sudo lshw -C network" to discover which is your WiFi/wireless card (hardware).

3) In my case the model was Realtek RTL8111/8168/8411. I obtained the driver here:

http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=5&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false#2

To discover which kernel was mine, I used the command "uname -r", this was necessary because for my case Realtek offers two different drivers for linux (2.4x and up to 4.7).

4) Install the driver ("cd" to the folder where you stored it and run the .sh)

5) Install "apptitude" with "sudo apt install aptitude"

6) Run "aptitude update && aptitude upgrade -y"

7) Run "sudo aptitude safe-upgrade -y"

8) See if the sattus of the WiFi bar changes, and routers appear listed.

9) Connect to the desired network and enter the password.

10) Welcome to the wonders of "Wirelless" internet, where the wires are hidden a few meters away!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.