17

I saw that on Windows machine you can increase the bass level of the sound that is outputted on headphones. How can achieve this on Ubuntu or Linux Mint using PulseAudio Equalizer?

1
  • As of now easyeffects is the only thing working for me, pulseeffects and pulseaudio eq aren't maintained anymore Commented May 15 at 17:05

2 Answers 2

33

UPDATE: Since I think that PulseAudio Equalizer is not being maintained anymore and it has some nasty bugs for years (Volume is set to 100% on login) I have found an alternative. The alternative is PulseEffects. It has more options and it's even better than PulseAudio Equalizer.

It even has better Bass booster (Bass Enhancer) than PulseAudio Equlizer. It can be started with system boot: System Settings > Sound > Output > PulseEffects(apps)

In order to get the nice bass sound on your headphones on Ubuntu 16.04+ and Mint 18+, you first need to have good headphones. I'm using Apple's headphones. The next thing you need to do is to put the preset on Party and slide the first column just little up, around ~15.4db and you will get that nice bass output just like on Windows machine.

PulseAudio Equalizer

2
  • That is so cool! Just tried it on Arch Linux and it's kinda the same thing as V4A on Android! Not sure if I can be more excited! :)))
    – Erikas
    Commented Sep 18, 2018 at 22:10
  • It's worth adding that if you're on battery your time to charge will be vastly reduced. Commented Oct 18, 2018 at 8:25
19

I'd like to add few details to Vladimir's comment about PulseEffects. On Android I've been using V4A audio effects application which greatly increased audio quality, especially bass boost. Unfortunately, I've been missing this kind of app on Linux for years and here it is - PulseEffects.

In order to get a powerful and clean bass boost in PulseEffects app, you need to manually reduce audio output in order to compensate bass boost (otherwise your speakers will sound like trash). Do the following in PulseEffects app:

  1. Enable "Limiter" and set "Input Gain" to approximately -15db.
  2. Enable "Bass Enchancer" and set "Amount" to approximately 12db.
  3. Ensure that "Limiter" is above the "Bass Enchancer" in the list (on the left).

Above settings works perfect to me with "Xiaomi In-Ear headphones pro", but your experience might be different. Just find a sweet spot yourself:

  • Use "Limiter" --> "Input Gain" to reduce audio volume.
  • Use "Bass Enchancer" --> "Amount" to increase bass boost.
4
  • PulseEffects was working for me, but now I believe it was causing almost random crashes. Some logs (next comment because this is too long)
    – Salami
    Commented Jan 5, 2019 at 15:28
  • E: [alsa-sink-ALC293 Analog] alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 342852 bytes (1943 ms). E: [alsa-sink-ALC293 Analog] alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_hda_intel'. Please report this issue to the ALSA developers. E: [alsa-sink-ALC293 Analog] alsa-util.c: snd_pcm_dump(): E: [alsa-sink-ALC293 Analog] alsa-util.c: Soft volume PCM E: [alsa-sink-ALC293 Analog] alsa-util.c: Control: PCM Playback Volume E: [alsa-sink-ALC293 Analog] alsa-util.c: min_dB: -51
    – Salami
    Commented Jan 5, 2019 at 15:28
  • 1
    It works for me, but music is breaking up, using Ubuntu 18.10 and Ideapad 320 (4 CPUs). Glad for the open-source world we live in. I love Linux/Ubuntu, especially being dev... but what a piece of mess is it when you need to do something simple like playing a music or print something with correct margins :) Commented Jan 18, 2019 at 8:58
  • 1
    On ArchLinux you need package calf for limiter and bass enhancer plugins. For more info see here
    – user958654
    Commented Sep 28, 2019 at 11:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .