1

Recently I did some updates and when I restarted, my display stayed blank. I figured it was because the update so I switched my monitor over to the motherboard's port. I'm currently using integrated graphics to troubleshoot this issue.

glxinfo | grep -i vendor

shows Mesa Project and SGI and Intel open source.

When I checked the driver manager, it said the Nvidia drivers were installed and being used, but when I ran nvidia-smi, no output showed. I first tried reinstalling the Nvidia drivers by doing:

sudo apt-get remove --purge nvidia-*

sudo add-apt-repository ppa:graphics-drivers/ppa

and rebooting, but nvidia-smi still displays nothing.

Then I tried blacklisting the open source drivers which it may have defaulted to. In that process, I noticed there was no xorg.conf file where it should have been, only xorg.conf.backup and xorg.conf.failsafe, etc. So I ran

cp xorg.conf.backup xorg.conf

and that only made matters worse - on boot it wasn't able to detect display settings and some menu came up about configuration but my mouse/keyboard stopped working. I mounted the filesystem and reverted the changes I made, so that's where I'm at now.

Something is goofy here, because lsmod | grep nouveau returns some lines (video, wmi, drm, ttm, ...) but nvidia still shows nothing.

doing:

grep LoadModule /var/log/Xorg.0.log

gives a list of modules - glx, intel, modesetting, fbdev, vesa, fbdevhw,...

How do I get my system to recognize the correct Nvidia drivers and fix my xorg.conf?

update; grep "EE\|WW" /var/log/Xorg.0.log gives this:

(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.

I think it has something to do with installing ubuntu-desktop at some point...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.