6

Good morning, I know that this might sound simple but I would like to avoid any complication since I use TeX daily and I don't want to mess all the things up. I have installed texlive-full by command line on the terminal, i.e.

sudo apt-get install texlive-full

and I have discovered that the version offered by Ubuntu is from 2015. I have seen that there is a 2017 version of TeX and I would like to install it without problem. Is there a clean way to install over the 2015 version? If not, what are the commands from the terminal to be sure that the previous version is completely purged and then what are the new commands that I have to type in order to install the 2017 version? Is there a way to add a repository (maybe an official one) in order that any new version is updated automatically without any future worry?

I'm sorry for my poor English, and I hope that this question does not result a repetition, since I would like a kind of guide to install properly the new version of TeX over the previous one, but I have not done anything for now, so I do not want to solve problem in the installation, I would like to know I to make the installation.

  • 1
    I'm voting to reopen this question, because pulling in packages from later releases is just one possible way to install TeX Live 2017 in Trusty. See my answer for another. – David Foerster Nov 9 '17 at 16:25
3

You can install TeX Live 2017 from Jonathon F’s PPA:

sudo add-apt-repository ppa:jonathonf/texlive-2017
sudo apt update
sudo apt full-upgrade -f texlive-full

You may run into a package compatibility error when you upgrade straight to TeX Live 2017 without the complete removal of a previous TeX Live installation(thanks mrek). See Install texlive 2017 on Ubuntu 16.04 LTS for solutions(thanks dexteritas).

  • As a reference for future users, I found this explanation about apt dist-upgrade useful: askubuntu.com/questions/81585/… – Luis Nov 9 '17 at 16:19
  • 3
    I don't recommend doing this. It simply breaks your packages: bash dpkg: error processing archive /var/cache/apt/archives/texlive-fonts-extra-doc_2017.20170619-1~16.04.york0_all.deb (--unpack): trying to overwrite '/usr/share/doc/texlive-doc/latex/mweights/README', which is also in package texlive-latex-extra-doc 2015.20160320-1 dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Errors were encountered while processing: /var/cache/apt/archives/texlive-fonts-extra-doc_2017.20170619-1~16.04.york0_all.deb E: Sub-process /usr/bin/dpkg returned an error code (1) – mrek Jan 13 '18 at 12:40
  • Look here for a solution of the error you will get after this (as mentioned by mrek). – dexteritas Mar 25 at 13:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.