4

My laptop is asus vivobook X556UQ. I have integrated intel graphic card and nvidia geforce 940mx.

After installing nvidia drivers and nvidia x server I have black screen when I awake laptop after suspend I get a weird error.

The screen is completely black, except for one line of code:

[ 44.351019] rtc_cmos 00:01: Alarms can be up to one month in the future

The only solution is to long-press the physical power button until the machine shuts down.

  • Look this: ubuntuforums.org/showthread.php?t=2367382 – Redbob Sep 9 '17 at 19:56
  • Thank you @Redbob for your answer. Actually, that guy hasn't solved his problem. He just switched back to nouveau driver. – Sadman Sep 12 '17 at 17:39
  • I already experienced that. NVIDIA proprietary drivers not always coexist pacifically to hardware they are proposed to do. Good that you got solved that. You could put it as an answer - with details of course - so it will be useful to other users. – Redbob Sep 12 '17 at 18:09
  • @Sadman Do you have an M.2 PCIe NVMe-enabled SSD installed? – WinEunuuchs2Unix Feb 11 '18 at 18:46
  • Switching to Intel (Power Saving Mode) did not work for me. I had to uninstall the 'recommended' Nvidia drivers and use Nouveau drivers instead. – Chris May 7 '18 at 12:40
4

This solution works for me. Ubuntu 16.04, Asus laptop.

Open Applications -> System Tools -> Administration -> NVIDIA X Server Settings

Choose PRIME Profiles and then click Intel (Power Saving Mode)

0

If you're using the nvidia drivers, read this post: SUSPEND , RESUMING and WAKEUP with nvidia370.28. It tells how to configure your driver to work propely at wakening up from hibernate and suspend.

If you have any issue with looping at login screen, ubuntu stuck at login loop after nvidia drivers

  • 1
    It may be helpful to summarize the most important information in the first link you provided, in case the site is taken down in the future or the link breaks. – Hee Jin May 7 '18 at 15:45
0

I encountered the same problem, though I'm using Ubuntu 18.04. In my case, I solved the problem by switching from Gnome to Gnome Wayland. I don't know exactly why but it became a no longer issue. You might consider trying it.

Another option is to change the primary setting from Nvidia to Intel. You can easily do that by typing

sudo prime-select intel 

in the terminal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.