0

I have to restart my network-manger once in an hour(random time) to get internet working, even after having good wifi signal all of sudden network is down.

Environment Ubuntu 16.04 and realtek wifi adapter.

**rfkill list**
0: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

**lspci -knn | grep "net" -A3**
07:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 07)
    Subsystem: Hewlett-Packard Company RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [103c:80c1]
    Kernel driver in use: r8169
    Kernel modules: r8169
0d:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330] [1002:6660] (rev 83)

lspci -knn | grep Net -A3; rfkill list

13:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
    Subsystem: Hewlett-Packard Company RTL8723BE PCIe Wireless Network Adapter [103c:804c]
    Kernel driver in use: rtl8723be
    Kernel modules: rtl8723be
0: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
  • 1
    Please edit your question and add output of lspci -knn | grep Net -A3; rfkill list terminal command. – Pilot6 Sep 9 '17 at 15:55
  • 1
    Is it a USB adapter? Then post the lsusb output. – Pilot6 Sep 9 '17 at 16:16
  • It is not USB adapter, if i restart network-manger it works fine – vishwanath patil Oct 19 '17 at 20:17
  • Please edit your question and add output of lspci -knn | grep Net -A3; rfkill list terminal command. – Pilot6 Oct 19 '17 at 20:56
  • I have added it – vishwanath patil Oct 20 '17 at 7:08
0

You can fix it by upgrading the kernel to 4.10.

Run

sudo apt install linux-generic-hwe-16.04

and reboot.

  • I get following on trying that ,linux-generic-hwe-16.04 is already the newest version (4.10.0.37.39). uname -a Linux vishwa-HP-Notebook 4.10.0-37-generic #41~16.04.1-Ubuntu SMP Fri Oct 6 22:42:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux – vishwanath patil Oct 20 '17 at 13:29
  • Then it should work OK, unless there is 1 antenna and a wrong one selected. – Pilot6 Oct 20 '17 at 14:12
  • askubuntu.com/questions/946503/… , earlier wifi was not working . It only worked for me after choosing write antenna – vishwanath patil Oct 20 '17 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.