0

I recently installed a dual boot of Ubuntu 17.04 on my laptop. In Windows and my main desktop PC (also Windows, although I think its Ubuntu 17.04 VMWare VM connects to the web fine as well), the laptop's wireless works perfectly, but in Ubuntu the laptop's wireless speed drops out randomly, though I am always still connected to my local network. I can reliably get a few minutes of non-zero wireless access speeds by restarting network manager with

sudo service network-manager restart

but after those few minutes all my attempts to access websites just hang, both in browser and through the shell. Restarting network-manager has been enough to get most basic software installed but obviously isn't a good long-term solution.

I've tried a number of possible fixes based on googling people who had similar problems, e.g. changing DNSSEC to off in resolved.conf, apt update'ing, apt upgrading, apt dist-upgrade'ing, changing my IPv4 Method to Automatic (DHCP) addresses only and listing 8.8.8.8, 8.8.4.4 in the DNS Servers entry, looking for additional proprietary wireless drivers to install (but none appear in the Ubuntu additional drivers tab), buying a cheap PAU wireless adapter ( this one: https://smile.amazon.com/gp/product/B00JDVRCI0/ref=oh_aui_search_detailpage?ie=UTF8&psc=1 ) after seeing it recommended as among the more compatible with Zesty Zapus, and probably a few other 'fixes' I'm forgetting.

None of those fixes worked. My networking background is nonexistent so I'm somewhat at wit's end. I downloaded and ran the Ubuntu Wireless & Networking forum's diagnosis script, but I don't see anywhere to attach it here and it's rather long; I'm happy to copy/paste sections of it or run other commands to explore the problem more.

Any thoughts on what might be wrong?

EDIT: Per request in the comments, lspci -knn | grep Net -A3 returns:

01:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821AE >802.11ac PCIe Wireless Network Adapter [10ec:8821] Subsystem: XAVi Technologies Corp. RTL8821AE 802.11ac PCIe Wireless Network >Adapter [1b9a:2482] Kernel driver in use: rtl8821ae Kernel modules: rtl8821ae 02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)

  • Please edit your question and add output of lspci -knn | grep Net -A3 terminal command. – user692175 Sep 9 '17 at 14:44
  • 1
    The RTL8821AE chipset is problematic and there is no straightforward definitive answer . – user692175 Sep 9 '17 at 14:50
  • Argh, well that's not what I was hoping to hear, haha. Thanks for the information, anyway. – NeverConvex Sep 9 '17 at 14:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.