0

Summary

I'm using Kubuntu on a laptop. Many (not all) of the KDE widgets stopped accepting keyboard inputs after I had to hard-reset the system due to unresponsiveness.

I need a way to make these widgets/plasmoids/etc start accepting keyboard inputs again to fix this problem.

Background

At one point several months ago, an app got the system stuck and I had to do a hard-reset. (It was unresponsive and couldn't even Ctrl + Alt + F1 my way to a terminal, so there was no other way.) After this, many (not all) of the KDE widgets/plasmoids/etc no longer accept keyboard inputs, even when they clearly have the focus. Obviously, something got messed up by the hard-reset, but I have no idea what it is.

Some of the affected areas include:

  • Application Launcher: cannot use the built-in search-as-you-type functionality;
  • Discover: can't enter admin password when asked while trying to install/remove software; must do this from terminal;
  • Network Manager: can't enter WiFi/VPN passwords
  • etc.

Some apps where I've not seen this issue include Amarok, Kate, Application Dashboard, etc.

I've tried re-installing the KDE environment and included apps/plasmoids/etc, including purging config files, and so on. None of my attempts have made a difference. In fact, the issue originated while using 16.10; upgrading to 17.04 did not change anything.

I've been using workarounds[1] for months, and trying different things in the meantime, but I'd really like to get this problem fixed once and for all already. It's extremely annoying, but I've found nothing else and even a bug report I filed back in May has received no attention.

Help from here is my last resort, since I'd really like to avoid having to nuke my system from orbit by re-installing the entire OS from scratch, formatting my /home/ partition (given that I don't know what/where the cause really is), and having to re-configure everything[2].

Update(s)

  • Upgrading to 17.10 did not help.

Footnotes

[1] For example, if I copy something, I can paste it into the widgets using the mouse (R-click >> Paste; Ctrl+V doesn't work). I'm also using Application Dashboard, but its behavior is not always consistent.

[2] It's the only way to be sure.

  • This solved problem for me without doing this painful reset :) – Daria Jul 15 at 7:01
0

I found a way to resolve the issue without having to take any drastic measures, such as reinstalling the system.

Resetting the KDE Plasma Workspace

To "reset" KDE Plasma and experience it anew, take the following steps:

  1. Log out from your session;
  2. Press Ctrl + Alt + F1 and log in at the terminal;
  3. Rename (not remove) the directories $HOME/.config/ and $HOME/.local/ to $HOME/.config.old/ and $HOME/.local.old/ respectively[1];
  4. Press Ctrl + D to log out (or type exit); and
  5. Press Ctrl + Alt + F7 to get back to the GUI login screen (i.e. greeter)

Note that apt-get remove ... and apt-get purge ... will not solve the problem. The issue is not a corrupted binary/package. The issue appears to be related to an environment/config issue that had the observed behavior as a side-effect, and purge does not remove those.

It was never obvious which one in particular was the culprit, so I had to nuke it from orbit[2].

Restoring your settings

The procedure above will reset your environment and it will be almost as if you had just logged in to your system for the first time (e.g. including wallpapers, etc).

For example, if you use browsers such as Brave or Chromium, you will need to copy the contents from $HOME/.config.old/brave/ into $HOME/.config/brave/ (or chromium if that's what you use) in order to get your old sessions back (e.g. tabs, accounts/passwords, etc.)[3]

You may need to do this with more than one application, so be ready to spend a few more minutes.

Some Apps that had to be restored

Some of the applications I had to take care of, besides the browsers above, included:

  • VirtualBox: Existing VMs were not listed; copy the VirtualBox sub-directory.
  • Kate: Configuration files; copy files matching the pattern kate* (e.g. katerc)
  • Discord: Prompted to create a new account; find the discord sub-directory and copy it like the browsers.

Obviously, you may need different changes based on your apps, but this should give you a general idea of what to do and what the results will be.


Footnotes

[1] For example, you can use the command mv $HOME/.config/ $HOME/.config.old, and so on, to rename the directories. Do not remove them with the rm command. You'll need them later.

[2] It's the only way to be sure...

[3] For example, you can use the command cp -r $HOME/.config.old/brave/* $HOME/.config/brave/ to recursively copy the directory and its sub-directories into its proper location.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.