I think a community wiki on problems (and solutions) when installing Ubuntu (10.10) on a Thinkpad Edge 11 would be nice (because I just got one ;)). I'll contribute with my own problems and solutions, and hope others will join too.

Known problems:

  1. No wifi-driver, solution: answer #1, answer #2
  2. Fan is loud, even though it's on auto. No solution. Thinkfan is a possible solution, but correction values for sensors should be supplied (mapping sensors to specific areas). Also, one sensor is between -100C and +100C - maybe some kind of deactivation would help.
  3. FN keys stop working: see below.
  4. No sound on headphones: see below.

4 Answers 4


To expand on lasseespeholt's reply on the Wireless chipset above, on my Thinkpad Edge 13 the wireless card is listed somewhat uniformatively as "Realtek Semiconductor Co., Ltd. Device 8176 (rev 01)".

Here's a step-by-step explanation of how to install the Realtek driver:

  • Download the driver from this page. The relevant section is "RTL8192CE-VA4"
  • sudo apt-get install build-essentials linux-source
  • cd /usr/src && sudo tar xfjv linux-source-2.6.35.tar.bz2
  • unpack the driver source and change to the directory contained
  • make
  • sudo su
  • make install

Against expectations, the last two steps cannot be replaced by a simple sudo make install because that fails with reference to a missing kernel/bounds.c.

The driver work well enough for me on Ubuntu 10.10.

UPDATE: Now there is a PPA (of which many thanks to the creator) which makes this much easier. It also has the important advantage that the driver persists through kernel upgrades. This works for maverick. Instead of the above, type:

sudo add-apt-repository ppa:lexical/hwe-wireless
sudo apt-get update
sudo apt-get install rtl8192ce-dkms

  • repo is not available any longer
    – JoachimR
    Sep 22, 2014 at 10:37

The FN Keys stop working

After working fine for a few months, the special "FN" keys on my Thinkpad Edge 13 - brightness, volume control, mute - suddenly stopped working. The problems seems to occur in Windows as well as in Linux. As it appears, this is a defect that can be resolved by installing a BIOS update. This thread shows you how to do it. Be sure to download the right boot CD image. As to why such a problem makes its appearance after working fine for months, only Lenovo engineers will know. On the plus side, the upgrade is quite easy, provided that you own a USB CD drive/writer.

This defect is reported to occur on Edge 13, Edge 14 and Edge 15 machines.

UPDATE: For many the trouble reappears some time after the BIOS update. The difficulty also seems to affect the lid close event. As a temporary fix, disconnect the A/C and remove the battery for a minute. The problem appears to be one of hardware/firmware rather than Linux. See this thread for more information.

  • It is stated in Lenovo's site that the bios update is just for Windows, which is kind of strange, because it's an iso image: support.lenovo.com/en_US/downloads/detail.page?DocID=DS013486 Jul 22, 2012 at 19:32
  • Oh, I have a problem. My CD isn't working and Lenovo doesn't read my USB as a bootable CD (used dd to write the iso). Any ideas how can I update the bios without a CD? Jul 22, 2012 at 21:21
  • 1
    Try simply disconnecting the AC and removing the battery to get back the ACPI functionality.
    – loevborg
    Jul 26, 2012 at 15:03
  • Worked like a charm. Why? Jul 30, 2012 at 10:08
  • 1
    It seems that sometimes the laptop's firmware or BIOS (?) gets into a bad state. Flashing the BIOS gets rid of that state, but so does disconnecting the battery.
    – loevborg
    Jul 30, 2012 at 11:29

No sound on headphones

AMD II Neo Dual-Core K325, 10.10 Netbook edition

I had no sound on my headphones and the built-in speakers were still playing sound with headphones plugged in. I followed the instruction from the first post at http://ubuntuforums.org/showthread.php?t=1043568, with the following option line in alsa-base.conf:

options snd-hda-intel model="ideapad"

After a reboot, the headphones worked and built-in speakers were turned off with headphones present. I am not sure that the option I used is optimal - it just did what I wanted.

  • On an Intel thinkpad edge, setting model="olpc-xo-1_5" worked.
    – loevborg
    May 2, 2011 at 18:10

No wifi-driver

Intel laptop, Realtek 8276 driver.

Solution: Install Realtek RTL8192CE-VA4 from Realtek. This will work even though it's not the same chip.

  • See my answer above for an easier, updated method.
    – loevborg
    May 2, 2011 at 18:06

Not the answer you're looking for? Browse other questions tagged .