0

I have an ASUS laptop with NVIDIA GeForce GTX 960M and a Skylake processor with integrated graphics running Ubuntu 16.04 LTS.

Observations:

  1. when I run lspci from the terminal (not with sudo), I get:

    ~$ lspci | grep VGA
    
    00:02.0 VGA compatible controller: Intel Corporation Skylake
    Integrated Graphics (rev 06)
    
  2. I have already switched the graphics after brand new installation of Ubuntu as follows:

    enter image description here

  3. I faced problem of freezing screen while installation so I did nouveau.modeset = 0 while booting and once booted I edited the grub file as per this solution i.e.

    GRUB_CMDLINE_LINUX_DEFAULT="nouveau.modeset=0". Then update-grub.
    
  4. On executing nividia-settings on terminal I get this key missing problem which I don't understand .

    enter image description here

Am I missing something very obvious? How do I switch to nvidia.

1

I recently had a similar issue after updating Ubuntu version to 17.10 and trying to set up NVIDIA drivers.

Symptoms were:

  • Indication of NVIDIA driver selected in additional drivers GUI window, but lack of nvidia-smi
  • Empty NVIDIA X Server Settings window (like on your screenshot)

Here's what I did:

  • Attempted to switch a driver from terminal: sudo apt install nvidia-375 (375 is not really critical, can be any other reasonable revision)
  • Carefully read the output of the command, noticed lines: Module build for kernel 4.13.0-16-lowlatency was skipped since the kernel headers for this kernel does not seem to be installed.
  • Installed missing headers sudo apt-get install linux-headers-$(uname -r)
  • Tried to install driver from terminal again (maybe rebooted prior to that and after headers installation)

Maybe in your case the reason is different, but I would still suggest same overall approach:

  • try running the failing command in terminal rather that from GUI (with maximum verbosity level if possible)
  • carefully observe the output
  • in case of any errors/warnings - make a research and try to fix them

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.