I have a Lenovo Y710 laptop that is running Ubuntu 16.04, my mouse is the Logitech marathon M705. I'm running a fresh boot and have been going over basic settings. This is my first time using Linux. I don't like mouse acceleration, as there is no option in the settings to disable it I found the below solution on the internet.

I typed:

sudo gedit /usr/share/X11/xorg.conf.d/90-mouse.conf

into a terminal and ran the below code.

Section "InputClass"
Identifier "mouse"
MatchIsPointer "on"
Option "AccelerationProfile" "-1"
Option "AccelerationScheme" "none"
EndSection

I restarted, mouse acceleration was off, I could change the speed of the touchpad, but I could not change the speed of my physical mouse. The slider worked and moved from slow to fast, but the mouse speed remained static at a relatively slow speed.

How do I fix this?

Try your preferred setting whit this command:

 xinput set-prop 'mouse' 279 0.9

You can change the 0.9 to a value from 0.0 to 1.0 (higher is faster).

After you found your preferred setting, make it permanent by adding the a line like

 Option  "Accel Speed" "0.9"

to the config file you edited before. Place it directly before the line "EndSection".

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.