3

I am trying to run an Ubuntu guest on Windows 10 using VirtualBox. I found the Ubuntu guest was running with slow response after the installation. I found some previous solutions for this problem by changing the settings under machine (like activating 3D acceleration, etc.), but I find my settings are locked. What is the solution for this? How to make the options active?

  • 2
    Please shut down the VM then make your changes! – George Udosen Sep 9 '17 at 4:53
2

Shutdown the Ubuntu 16.04 guest OS, then you can safely make changes in the VirtualBox Settings for that guest OS (click the Ubuntu 16.04 guest OS first to select it) and restart the guest OS to test your changes. Enable 3D Acceleration won't help. The changes that will improve performance are:

  1. Add another CPU thread in Settings -> System -> Processor. You can safely have 2 Processors instead of 1 Processor if you 4-8 CPUs.

  2. Add more Base Memory in Settings -> System -> Motherboard. You can safely allocate up to half of the RAM in your physical machine for the guest OS Base Memory.

  3. Optionally you can increase the Video Memory up to a maximum of 256MB from the terminal by running this command:

    VBoxManage modifyvm "name-of-Ubuntu-16.04-guest-OS" --vram 256
    
1

Certain configurations on Virtualbox can only be modified when the device in question isn't running, so please shut down your Virtual machine that's the only way those configurations can be set. And they will only work if your system (host OS) supports 3D Acceleration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.