1

Ubuntu used to have a supported feature for setting caps to backspace that got me hooked on the idea of doing that. It has sense been removed just like the f3 feature in the file manager. Regardless, I have figured out how to set in manually on start up with the following command

setxkbmap -option caps:backspace && xmodmap -e "clear Lock"

Works great. Until I start using my bluetooth headset. Then backspace magically turns back into caps lock

Any ideas about why this might happen? The two things seem completely unrelated to me, but it happens every time in some point of the bluetooth connection process

Basically I'm looking to make this setting more of a permanent fixture for the keyboard layout that I'm using

UPDATE: Seems to occur when I try to connect to by headset as a different profile In Blueman connecting as audio sink instead of headset. Its fine when bt first connects

1

This is untested, but what about doing it by editing /etc/default/keyboard instead, i.e. changing the line:

XKBOPTIONS=""

to

XKBOPTIONS="caps:backspace"

Not sure about that xmodmap command. Is it really necessary? AFAIK xmodmap is deprecated.

  • Thanks for the tip! The xmodmap command just makes it so that the caps key becomes repeatable. Its kinda frustrating to have your backspace key only be able to delete one character at a time when holding it – Paul Beaudet Sep 9 '17 at 1:59
  • @PaulBeaudet: Ah, thanks for explaining. Unfortunately I don't know how to do that in XKB (if it's at all possible). – Gunnar Hjalmarsson Sep 9 '17 at 2:03
  • So I tried setting the default layout config file, seems like it has the same issue. I appreciate the idea though. This is how I'll probably set this setting going forward – Paul Beaudet Sep 9 '17 at 2:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.