I have windows and ubuntu installed on two partitions. I was having ubuntu 11.10 till now, where in I never had any issue with the wired network connectivity. When I click on the network icon on the "taskbar" sort of thing, I can see sections for both "wired network" and "wireless network", and the wired network shows the network details when I simply plug in the lan cable. This works perfectly - just plug in and you are ready to go with wired internet.

I had to remove v11.10 and install v10.04 lts of ubuntu recently. Here, after installation I noticed that when you click the same network icon in the "taskbar" sort of thing, the section for "wired network" itself is missing. Instead, all i am presented are the wireless networks that are available in the vicinity. I tried adding a wired network using the network manager applet, but still it does NOT list the wired network details. Plugging in the lan cable has absolutely no effect on the system. No response.

I reverted to v11.10, and my wired network just simply works like magic.

Please tell me what is going wrong with ubuntu v10.04 lts in my system. Since I am pretty new to linux, please elaborate if possible any technical steps i need to take.

  • your question lacks important information which could help others provide assistance. please include information on the card type, and a link to basic debug information (i.e. pastebin of lspci/dmesg output) start here: help.ubuntu.com/10.04/internet/C/troubleshooting.html – nathwill Mar 29 '12 at 22:11

You would need to be a developer to answer such a question ... I would think. Why did you have to remove v11 in the first place? Besides it doesn't sound like its an applet issue, more like your NIC drivers need updating or need installation. The wireless is sort of automatic for a normal Ubuntu install. Back into Windows and make sure ... 1. NIC is turned on. 2. There is an IP address present. 3. Cable is sucurely connected to LAN port. If there is no IP staus or IP address avalible -- it is a driver issue, go to machines manufacture and download latest network card drivers and install with windows, run Windows updates. The great thing about linux is that it can handle multiple installation on the same machine. REINSTALL V11.

  • I had to remove v11 and install v10 due to several reasons which I would rather not list here. Now coming to the driver issue - see, it works perfectly in windows AND UBUNTU v11. It is just NOT WORKING in ubuntu v10.04 alone. If you think it is still a problem with missing drivers, could you please let me know how to get the network drivers for ubuntu v10.04 lts? I use a toshiba portege R835 model laptop and I couldnt find drivers for linux. Any help is much appreciated. Thanks. – arun Jan 14 '12 at 15:53
  • i just ran 'sudo ifconfig' and it lists only the "lo" details. the "eth0" details are missing in the output. Also, i ran the "lspci" command, and the network card details are missing from the output. Does this mean that the ethernet card drivers for ubuntu 10.04 is missing? Why is it working out-of-the-box for ubuntu 11.10??? – arun Jan 14 '12 at 17:00
  • Understand the importance of having the machine original driver up to date. Linux uses a logical approach and creates software that relies on the original drivers software.I don't think linux created an entire set of driver software for every specific computer, that the linux way, with the foundation set with the original software, linux just makes use of its kernel to code software in a different way. Linux sees everything the same way, you have a toshiba it see a toshiba. Download the most current drivers for your toshiba csd.toshiba.com/cgi-bin/tais/support/jsp/home.jsp – Jim Schafer Jan 14 '12 at 17:01
  • do a "sudo ifup eth0" turn on the interface or do a simple reboot to turn the interface back on. And again you'd have to be a developer to answer the question to its fullest. Relax, it only linux. – Jim Schafer Jan 14 '12 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.