1

I am running the Xmonad window manager on Ubuntu 17.04. When I start an Xmonad session, gnome-screensaver is not running (as I want). Whenever the first on-screen notification occurs, gnome-screensaver is launched as well. I would like to stop whatever autolaunch mechanism is doing this.

See below for an example. Notice that notify-osd is launched in response as expected but so is gvfsd, gvfsd-fuse, and gnome-screensaver.

$ ps -x -o pid,tty,stat,command
  PID TT       STAT COMMAND
 1920 ?        S    lightdm --session-child 13 20
 1934 ?        Ss   /lib/systemd/systemd --user
 1955 ?        S    (sd-pam)
 2033 ?        Ss   /usr/bin/dbus-daemon --session --address=systemd: --nofork --nopidfile --systemd-activation
 2056 ?        Sl   /usr/bin/gnome-keyring-daemon --daemonize --login
 2059 ?        Ss   /home/jumper/.xmonad/xmonad-x86_64-linux
 2142 ?        Ss   /usr/bin/ssh-agent /usr/bin/im-launch xmonad-session
 2151 ?        Ss   /bin/sh -c urxvt
 2152 ?        R    urxvt
 2153 ?        S    urxvt
 2154 pts/0    Ss   bash
 2270 pts/0    R+   ps -x -o pid,tty,stat,command

$ notify-send "Test notification" "This is a test"

$ ps -x -o pid,tty,stat,command
  PID TT       STAT COMMAND
 1920 ?        S    lightdm --session-child 13 20
 1934 ?        Ss   /lib/systemd/systemd --user
 1955 ?        S    (sd-pam)
 2033 ?        Ss   /usr/bin/dbus-daemon --session --address=systemd: --nofork --nopidfile --systemd-activation
 2056 ?        Sl   /usr/bin/gnome-keyring-daemon --daemonize --login
 2059 ?        Ss   /home/jumper/.xmonad/xmonad-x86_64-linux
 2142 ?        Ss   /usr/bin/ssh-agent /usr/bin/im-launch xmonad-session
 2151 ?        Ss   /bin/sh -c urxvt
 2152 ?        S    urxvt
 2153 ?        S    urxvt
 2154 pts/0    Ss   bash
 2398 ?        Sl   /usr/lib/x86_64-linux-gnu/notify-osd
 2401 ?        Ssl  /usr/lib/gvfs/gvfsd
 2406 ?        Sl   /usr/lib/gvfs/gvfsd-fuse /run/user/1001/gvfs -f -o big_writes
 2417 ?        Sl   /usr/bin/gnome-screensaver --no-daemon
 2428 pts/0    R+   ps -x -o pid,tty,stat,command
  • 2
    I'm puzzled, usually graphical autostart is handled by a compositor, but you're running your own XMonad. May be you shall just try removing gnome-screensaver? Alternatively, if it is not WM, may be for some reason it's done be DE. I'd also try grep -rnI screensaver /etc/. – Hi-Angel Sep 8 '17 at 19:57
  • s/DE/DM. I meant Display Manager. – Hi-Angel Sep 9 '17 at 18:21
  • I did install xmonad through Ubuntu, so I launch through the login screen (presumably through xmonad.desktop but I am out of my depth here). Doing the grep you suggested brings up one interesting result: /etc/xdg/autostart/gnome-screensaver.desktop, which as the following text: (next comment) – John Jumper Sep 13 '17 at 19:43
  • [Desktop Entry] Type=Application Name=Screensaver Comment=Launch screensaver and locker program Icon=preferences-desktop-screensaver Exec=gnome-screensaver OnlyShowIn=GNOME-Flashback; NoDisplay=true X-GNOME-Autostart-Phase=Application X-GNOME-Autostart-Notify=true X-GNOME-Bugzilla-Bugzilla=GNOME X-GNOME-Bugzilla-Product=gnome-screensaver X-GNOME-Bugzilla-Component=general X-GNOME-Bugzilla-Version=3.6.1 X-Ubuntu-Gettext-Domain=gnome-screensaver – John Jumper Sep 13 '17 at 19:43
  • Removing that gnome-screensaver.desktop file did not change anything unfortunately. – John Jumper Sep 13 '17 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.