0

I have a desktop PC running Ubuntu 16.04 in the living room in which i am facing a strange behavior concerning the front panel audio output. Yesterday, after noticing i was not having sound coming out of the jack i followed the guidelines in this thread from which i managed to get fixed in the current session.

Unfortunately, every time i reboot the system, the audio is only produced in back panel while front panel jack is activated only if i open a terminal window (either via launcher or shortcut ctrl-alt-t). Soon after i have an open terminal, front audio jack/headphones start working and i have sound.

Checking alsamixer parameters in a terminal before logging in an user, every setting appear to be normal and Headphone option is not muted.

Checked shortcuts keys in OS and there are no conflicts with media/sound related tasks.

I don't mind having to open and close a terminal to get my headphones working. The problem is that the PC is used by other people in my house that barely know what a terminal is and it would be a very uncomfortable workaround to explain.

This is such a very odd behavior that i got curious with so i am sharing it with anyone who might might tip the possible silly root cause.

I really appreciate any help you can provide.

  • Look at your alsamixer if auto-mute is enabled. It's at right-side. Maybe you have to disable it, to get headphones work from startup. Other option is you do a script with that command within and adding it to your Session Applications Preferences. – Redbob Sep 8 '17 at 15:58
  • 1
    In fact, the solution you appointed indicates to store that command at ~/.bashrc. It indicates that you wil execute that command only when you open a terminal session. Creating a script with that command and attaching as I did above solves your problem. – Redbob Sep 8 '17 at 16:10
0

Create a script with that command you said at other issue. (I suggest you to store at ~/unmute.sh)

#!/bin/bash
/usr/sbin/alsactl --file /home/<user>/.config/asound.state restore

So you could do this:

enter image description here

| improve this answer | |
  • Just did this. I don't know why but the script is not running at startup, i am looking into why its not running. Headphone volume going back to 0 whenever system start. It only works if i run the script in a terminal. Thank you for the quick response. ;) – Guilherme Sep 9 '17 at 21:42
  • Perhaps alsactl is not reachable without complete name /usr/sbin/alsactl at login startup. I edited my answer. Maybe so it will work without need to open a terminal. – Redbob Sep 9 '17 at 22:14
  • Ok, just did this. Still volume 0 & muted at startup. I named my file .unmute.sh so it is hidden but i don't think its the cause. – Guilherme Sep 9 '17 at 22:33
  • But the script is executed? Look at /var/log/syslog if it's executed. In a terminal session, type amixer controls, and output the result here, please. If you prefer, put it in your question. – Redbob Sep 9 '17 at 22:42
  • Done. After entering full command path in Edit Startup Program it's now working. For some reason ~/ is not accepted (?). Thank you very much for your patience! – Guilherme Sep 9 '17 at 22:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.