1

This seems to be an all time re-occuring issue, but the Answers I found didnt help me.

I am having trouble installing a newer version of R on my Ubuntu 16.04. I followed the answer here Installing latest version of R-base and here https://cran.rstudio.com/bin/linux/ubuntu/README.html and added deb https://cran.uni-muenster.de/bin/linux/ubuntu zesty/ to my /etc/apt/sources.list.d folder as file called r.list

but this does not work for me. After removing R and trying to install r-base I still get:

$sudo apt-get install r-base
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 r-base : Depends: r-base-core (>= 3.4.1-2zesty0) but it is not going to be installed
      Depends: r-recommended (= 3.4.1-2zesty0) but it is not going to be installed
      Recommends: r-base-html but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Why are the dependencies not being installed?

Any idea how i can get the R version from Zesty Zapus (17.04) on my 16.04LTS ubuntu?

0

The exact same issue occurred in my ubuntu 17.10. I solved it by downloading libpng12-0 from https://packages.ubuntu.com/xenial/amd64/libpng12-0/download

Then install it with command:

sudo dpkg -i libpng12-0_1.2.54-1ubuntu1_amd64.deb

Finally, run commend below to install R (assume you have already added R repository):

sudo apt-get install r-base-dev

I hope it will help you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.