2

I have downloaded eclipse-platform-3.7-linux-gtk-x86_64.tar.gz.

Using Ubuntu 10.10 64-bit on Intel 64-bit processor.

While trying to unpack the contents (either double-click or right-click & open-with-archive-manager) I get this error:

gzip: stdin: unexpected end of file<br/>
tar: Unexpected EOF in archive<br/> 
tar: Error is not recoverable: exiting now

Is there any remedy to repair it? or is the downloaded file corrupt & needs to be re-downloaded?

3
  • I renamed the file from ".tar.gz" to just ".tar" Then fired command "tar xzvf eclipse-platform-3.7-linux-gtk-x86_64.tar It did some unpacking. Then at a certain point, the same error is thrown as I wrote in my question. – Vineet Jan 14 '12 at 13:29
  • There are two ways to go troubleshooting. Knock out the easy one first: md5sum eclipse-platform-3.7-linux-gtk-x86_64.tar.gz which should match exactly with the Md5 sum published for that file, which I think may be here, but not sure: download.eclipse.org/eclipse/downloads/drops/R-3.7-201106131736/… – user8290 Jan 14 '12 at 14:45
  • Thanks Chris for your input. In the meantime, I booted to Win7 and extracted the contents through WinRar. It extracted.... – Vineet Jan 14 '12 at 17:09
3

By the looks of you haven't gotten the entire archive downloaded. Try to download it again and have another go at it.

I just had a go with it. Downloaded the file from the eclipse site. The link I got was http://eclipse.mirror.garr.it/mirrors/eclipse//eclipse/downloads/drops/R-3.7-201106131736/eclipse-platform-3.7-linux-gtk-x86_64.tar.gz. This file checks out ok on md5sum and extracts without any problems.

4
  • I re-download the same. But no success. Same error. – Vineet Jan 14 '12 at 14:11
  • Had to try for myself. No problems here. Updated my answer with the download link I got from eclipse web. – Zoke Jan 14 '12 at 15:10
  • In the meantime, I booted to Win7 and extracted the contents through WinRar. It extracted.... Now further problem is-- I added a line in "eclipse.ini" as -- "...-Djava.library.path=/usr/lib/jni after -vmargs. But it does not open Eclipse. It says "Could not display "/tmp/eclipse/eclipse"." There is no application installed for executable files”. What do I need to do for this? – Vineet Jan 14 '12 at 17:06
  • I sorry to say that I know nothing of eclipse and how it works. – Zoke Jan 14 '12 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.