My lenovo t470s laptop, running ubuntu 16.04 boots me into emergency mode. Things were ok yesterday.


Running mount /boot/efi, yields FAT-fs (nvme0n1p1): IO charset iso8859-1 not found and Mount: wrong fs type, bad option, bad superblock on /dev/nvme0n1p1, missing codepage or helper program or other error

Running systemctl —failed, tells me that boot-efi.mount and systemd-modules-load.service have failed

Kernel is: 4.10.0-33generic #37~16.04.1-Ubuntu SMP Fri Aug 11 14:07:24 UTC 2017 x86_64 x86_64 GNU/Linux`

Errors (and select warnings) found with jounralctl -xb:

  • Could not open moddep file: ‘lib/modules/4.10.0-33-generic/modules.dep.bin’

  • Failed to lookup alias ‘lp’: Function not implemented (This repeats 2 more times with a couple of variations)

  • dns-clean.service: Job dis-clean.service/start failed with result ‘dependency’

  • local-fs.target: Job local-fs.target/start failed with result ‘dependency’

  • FAT-fs (nvme0np1): IO charset iso8859-1 not found

  • boot-eft.mount: Mount process exited, code=exited status=32 Failed to mount /boot/efi

It's possible some updates installed yesterday, but unfortunately I don't recall what they were.

I'm unclear how to debug/fix things to get them back to a runnable state. Any help is appreciated!

And of course, let me know what else I can provide to help troubleshoot.


4 Answers 4


Executing the following command in recovery mode solved the problem for me:

$ depmod

  • Worked for me as well. First press enter to login than depmod and exit. Could start and restart the system again.
    – zyexal
    Feb 24, 2020 at 7:49

Fixed, I think...Thanks all who helped.

Unfortunately the exact method by which it was fixed is unclear. Due to my growing frustration and need to get things fixed, I was not atomic enough in my troubleshooting process, so it may of been one of two things, both suggested by @bodhi.zazen in comment above.


  1. From recovery mode, running the modprobe commands here: https://askubuntu.com/a/571644/699673
  2. Booting into a previous version of the kernel (from recovery mode, I selected an earlier version of the kernel from the list of options).

I performed these two operations in succession, so it is unclear which fixed things.

I have updated and rebooted several times thus far. If anyone can suggest further checks to run to confirm stability, that would be appreciated.

  • I went through the same steps atomically and choosing the previous version of the kernel allowed me to fix the issue Dec 30, 2019 at 6:10

I had the same issue with a Lenovo T480s and Mint 19.2 (built on Ubuntu 18.04).

$ modprobe nls_iso8859-1
modprobe: ERROR: ../libkmod/libkmod.c:586 kmod_search_moddep() could not open moddep file '/lib/modules/4.15.0-66-generic/modules.dep.bin'
modprobe: Module nls_iso8859-1 not found in directory /lib/modules/4.15.0-66-generic

As suggested in this answer, running:

$ depmod

in recovery mode, then rebooting fixed the problem for me.

  • 1
    That solved my issue, thank you.
    – ZedTuX
    Mar 27, 2020 at 10:56
  • 1
    The error occurred out of the blue and gave me a mini heart attack. This little solution worked for me and saved me a LOT of headache. Thanks a lot.
    – Ejaz
    Sep 7 at 11:37

Lets first check your file system for errors.

To check the file system on your Ubuntu partition...

  • boot to the GRUB menu
  • choose Advanced Options
  • choose Recovery mode
  • choose Root access
  • at the # prompt, type sudo fsck -f /
  • repeat the fsck command if there were errors
  • type reboot

If for some reason you can't do the above...

  • boot to a Ubuntu Live DVD/USB
  • start gparted and determine which /dev/nvme0nXpY is your Ubuntu EXT4 partition
  • quit gparted
  • open a terminal window
  • type sudo fsck -f /dev/nvme0nXpY # replacing X and Y with the numbers you found earlier
  • repeat the fsck command if there were errors
  • type reboot
  • Thank you for the reply. I apologize for the lack of formatting on this comment.... I tried both methods, neither worked. Booting into USB key, output of sudo fsck -f /: fsck from util-linux 2.27.1 fsck.fat 3.0.28 (2015-05-16) /dev/nvme0n1p1: 8 files, 870/130812 clusters . Gparted reported 3 partitions: /dev/nvme0n1p1 | name:EFI system partition | file system: fat32 | size:512 MB | Used 4.41 MB | flags: boot, esp . /dev/nvme0n1p2 | name: | file system: ext2 | … . /dev/nvme0n1p3 | name: | file system: crypt-auks | … . Sep 7, 2017 at 22:38
  • @devlindeboree Normally you'd place that output into your original question using copy/paste. I think that some of your information got cut off, but since you booted from the USB flash drive, the command would probably be sudo fsck -f /dev/nvme0n1p3.
    – heynnema
    Sep 7, 2017 at 23:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.