I built a Ubuntu minimal installation (32-bit) to a VirtualBox Machine. Everything worked without a hitch, and the first things I installed were xorg and lxqt, including dependencies. It booted up fine, and I thought it was working well, until I tried to add a new repository in the terminal.

Here's the command:

sudo add-apt-repository ppa:nilarimogard/webupd8

Once I hit enter, I am immediately met with this error:

sudo: add-apt-repository: command not found

I've also tried this command:

sudo add-apt-repository ppa:kdenlive/kdenlive-stable

with the same result. Running sudo apt-get install firefox installs Firefox with no problems; it's adding new repositories that causes the issue. Aside from installing a few programs via synaptic, I have done nothing to the system. I have not un-installed anything. Does anyone know what is going wrong?


You can install add-apt-repository by

sudo apt-get install software-properties-common


pilot6@Pilot6:~$ dpkg -S /usr/bin/add-apt-repository
software-properties-common: /usr/bin/add-apt-repository

Not the answer you're looking for? Browse other questions tagged or ask your own question.