how to install google gadgets in ubuntu 11.10? Any ppa s available? .Source code is available on their website how to package it? If it is not packaged yet ,how can i build it from source code?

up vote 6 down vote accepted
+50

As a compilation exercise, it is just about possible to force google-gadgets to compile - however I'm doubtful whether google-gadgets for the desktop is useful since Google themselves has discontinued support

Thus this answer will give you enough pointers to achieve this under 11.10:

enter image description here


How to compile:

Install the prerequisites:

sudo apt-get install build-essential bzr autoconf libtool

sudo apt-get install build-essential zip flex desktop-file-utils shared-mime-info zlib1g-dev libgtk2.0-dev libxml2-dev libdbus-1-dev librsvg2-dev libcurl4-gnutls-dev libgstreamer-plugins-base0.10-dev network-manager-dev libqt4-dev libstartup-notification0-dev libltdl-dev libqt4-dev

get the source

cd ~/Downloads
bzr branch lp:googlegadgets
cd googlegadgets/

to generate something to compile

sh autotools/bootstrap.sh
./configure

to compile

Now - this isnt straightforward since there is various parts of the code that dont compile in 11.10.

Thus it is interative - fix and then run make. Repeat this until it fully compiles.

The files to edit are:

gedit ggadget/gtk/single_view_host.cc &
gedit ggadget/dbus/dbus_utils.cc &
gedit extensions/gst_video_element/gadget_videosink.cc &
gedit extensions/linux_system_framework/network.cc &
gedit extensions/linux_system_framework/wireless.cc

To take a purist approach - you'll need to replace the code with 11.10 equivalents. Taking the blunderbuss approach ... I just commented out the various sections, or where an int variable needs to be assigned - just assigned it a value of 0.

Obviously - just commenting out code will leave these areas non-functional - I'll leave that to an interested person to investigate the 11.10 equivalents...

Use the make error to comment out the relevant sections ( 'C' comments are /* ... */ and // ...)

to install

sudo make install

to run

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib
gg-qt &

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.