I have permament problem when using WLAN with my Lenovo ThinkPad x121e. The wireless network adapter in use is this one:


01:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)

The connection normally works OK for some time and then starts to slow down and eventually disconnects. Sometimes the connection is reestablished seconds later, sometimes it takes 30 or more seconds, sometimes it does not reconnect at all.

This problem occures with every driver I tried up to now. Especially the kernel driver

Linux ThinkPad 3.0.0-14-generic #23-Ubuntu SMP Mon Nov 21 20:28:43 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

and Realteks driver that can be found here. The driver I'm using at the moment is the one found in this ppa: ppa:tista/x120e.

Here is another link to www.thinkwiki.org that hints at a "Low Power State" (LPS) option in realtek's driver but it seems that it cannot be disabled in the current driver.

Is there a way to get a more stable WLAN with this setup?

Some more system information:

lshw -class network:

   description: Wireless interface
   product: RTL8188CE 802.11b/g/n WiFi Adapter
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:01:00.0
   logical name: wlan0
   version: 01
   serial: 38:59:f9:db:e6:83
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=rtl8192CE driverversion=0006.0321.2011 firmware=56 ip= latency=0 link=yes multicast=yes wireless=802.11bgn
   resources: irq:17 ioport:3000(size=256) memory:f0200000-f0203fff

iwconfig wlan0:

wlan0     802.11bgn  ESSID:"xxx"  Nickname:"rtl8192CE"
      Mode:Managed  Frequency=2.452 GHz  Access Point: A2:05:43:2F:6E:8E   
      Bit Rate=65 Mb/s   
      Retry:on   RTS thr:off   Fragment thr:off
      Power Management period:0us  mode:All packets received
      Link Quality=100/100  Signal level=0 dBm  Noise level=-120 dBm
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:0  Invalid misc:0   Missed beacon:0

ifconfig wlan:

wlan0     Link encap:Ethernet  HWaddr 38:59:f9:db:e6:83  
      inet addr:  Bcast:  Mask:
      inet6 addr: fe80::3a59:f9ff:fedb:e683/64 Scope:Link
      RX packets:117385 errors:0 dropped:0 overruns:0 frame:0
      TX packets:85652 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:115417879 (115.4 MB)  TX bytes:10463799 (10.4 MB)
      Interrupt:17 Memory:ffffc900037a8000-ffffc900037a8100 
  • I have exactly the same problem on a x121e. With the ppa drivers its usable, but reception is bad (even though it shows good signal strength) and sometimes it losses connection for no reason...
    – Uli
    Jan 17, 2012 at 14:49
  • Possible duplicate of askubuntu.com/questions/90933/…
    – Thomas
    Jan 21, 2012 at 13:17
  • try to use static ip ..i got the same problem i googled it & i have installed some path i didn't remember i think that was wireles path for kernal ..something like that ..
    – One Zero
    Jan 23, 2012 at 17:14
  • This seems to be much better now with 12.04. A clean install from the 12.04 live cd (no additional driver or setting) works more stable than anything with 11.10.
    – Thomas
    Apr 27, 2012 at 6:05
  • OK, it is NOT better with 12.04. Onw day everything is fine, the next day, the old problem is back again. No idea why ...
    – Thomas
    May 1, 2012 at 19:51

11 Answers 11


I finally fixed this problem by compiling and installing the latest drivers from Linux Wireless in Ubuntu 12.04, in my case the "compat-wireless-3.5.1-1-snpc.tar.bz2" package: http://wireless.kernel.org/en/users/Download/stable/

One needs the header files for his kernel and the build-essentials package. I recommend also to run the script "driver-select" with the option rtlwifi before compiling because one doesn't need the other drivers and it reduces building time:

sudo apt-get install linux-headers-$(uname -r) build-essential

tar jvxf compat-wireless-3.5.1-1-snpc.tar.bz2
cd compat-wireless-3.5.1-1-snpc
./scripts/driver-select rtlwifi
sudo make install

But the downside is you have to rebuild the driver after every kernel update.

I'm running the driver for two days now with excessive closing and opening the lid and didn't get any disconnects.

  • The is the linux-backports-modules-cw-3.3-precise-generic package. I'm giving it a try.
    – Thomas
    Sep 2, 2012 at 13:59
  • Now I’m on 12.10 on my notebook and the wireless behaves a lot better with stock kernel and drivers, but it still randomly disconnects or doesn’t connect at all when the signal strength is low or when you are in a network with a lot of clients. Apr 24, 2013 at 21:10
  • I'm not able to download compat-wireless- every link pointing to the orbit-lab.org is forbidden for me except their homepage and links from it, how may I get this file? Dec 25, 2013 at 0:56

The problem could be caused by channel hopping (and the new Linux kernel).

I fixed it mostly with compile the driver by my own and install it. 2nd thing I did was to scan for networks if the network is breaking.

I entered in terminal watch sudo iwlist wlan0 scan.

With this the driver kept awake. Another fix I used is to press Fn+F5 to disable wifi and then I do the same a few seconds later.

One more thing I tried:

sudo modprobe -r rtl8192ce
sudo modprobe rtl8192ce

This reloads the driver for wifi. I also ping sometimes the router, this keeps my wifi connection stable.


This link gave me the hint to try the option ips=0 for the module rtl8192ce to turn off all power saving with the wlan adapter. Up to now this gives me the best behaviour - no drop outs, no disconnects. This surely will have an efect on power consumption - we will see. I'm using the build in drivers with kernel 3.0.0-15 for now.


I ended up replacing the WLAN card as I was unable to get a stable connection.

For those wanting to do the same: The trick is to plug the card into the spare mini PCIe slot and not the WLAN card slot. This way the BIOS will not complain about unsuproted hardware. The spare slot is meant for a WWAN/UMTS card, but the WLAN antenna cables reach it just fine. It is really simple to do its just 3 screws for the panel and one for the card, plus the antenna plugs.

I bought a Intel Centrino Advanced - N 6200 card (half lenght PCIe) for 20€ and it works perfectly. Though I recomend using a full lenght PCI express card as thats what the slot is made for (I had to fix mine with tape, wich is a lot mare stable than it sounds).

  • I tried the same thing with an Intel Centrino 6205 card without any success. Do you have the AMD or the Intel model? What version is your BIOS?
    – Earthliŋ
    Apr 15, 2013 at 3:22
  • @user1205935 AMD modell, I'll have to check BIOS later. What didn't work for you? Did the BIOS complain about unsuported Hardware even when it was in the WWAN/UMTS slot?
    – Uli
    Apr 15, 2013 at 7:48
  • The BIOS didn't complain, I don't even get to the BIOS. (I posted my problem in the link above.) The computer is on, the screen is black, the fan is turning, but nothing is happening... I have an AMD model as well. Maybe I need to buy the 6200 instead?
    – Earthliŋ
    Apr 15, 2013 at 7:51
  • @user1205935 Well reading what you wrote there The problem might be that you didn't remove the old card, which I did. You can try with the tips postet here: todayifoundout.com/index.php/2010/02/…
    – Uli
    Apr 15, 2013 at 10:55
  • Thanks. I'll have to find some tools for that, then. Curious that a WWAN card is allowed to go there, but a WiFi card doesn't even make it to the BIOS...
    – Earthliŋ
    Apr 15, 2013 at 12:46

I did the same: disabled the WLAN port in the BIOS, removed the Realtek card and added a Intel Centrino 6200 to the WWAN port. I used a MiniPCIe adapter half->full (costs less than 5Eur) to secure the card in place.

  • Thanks for the tip, I'll look for such an adapter. This should probably be a comment, not an answer though
    – Uli
    May 10, 2012 at 13:37

hey i just did what is mentioned in the last part of the text (update feb 21 2011) http://www.hitxp.com/articles/software/ubuntu-fix-slow-wireless-internet-connection-speed-upgrading-11-04-natty-narwhal/ i get better results with that for thinkpad x121e ubuntu 12.04

  • I'm giving it a try - seems to work quite well for now, let's see how it does for the next days.
    – Thomas
    Jun 21, 2012 at 17:49
  • Seems to work fine
    – Thomas
    Jun 24, 2012 at 17:05

I was also having the same issue. I went through the process of compiling drivers from source, etc. But I still had the same problem. I would have access but it was extremely slow. I would have to release and reload the module it seems like every 5-10 minutes to keep any usable connection.

Now this was just annoying. So reading though more posts and testing multiple methods I finally found a solution that worked for me. I did the following.

From a fresh install:

sudo -i
apt-get update && apt-get dist-upgrade
apt-get install linux-packports-modules-cw-3.4-3.2.0-30-generic
nano /etc/modules (Added rtl8192ce to the end)

Changed ipv6 to ignore in network manager.

Did a reboot as usual.

When I first login sometimes I have to release the module and reload.

sudo modprobe -r rtl8192ce

(wait a few seconds)

sudo modprobe rtl8192ce

I've been testing all night downloading files from my server without any notable reduced speed, or loss of connection. As stated before sometimes I have to release the module and reload. But rarely only on boot.

I am using kernel version 3.2.0-30-generic, and the wlan card is the ASUS PCE-N15. I also use opendns server's don't think it makes a difference too much, but I prefer to use them.

I hope this helps anyone that was having the same problem. I know I was so close to going back to windows, but I had to try.

  • 1
    I tried to keep the card working properly, but in the end I could never maintain a stable connection. So I ended up changing wireless cards.
    – mywebslave
    Sep 25, 2012 at 9:01

Teach a man how to fish:

I had exactly the same problem: new ASUS 802-11bgn wireless card with a ralink rtl8192ce chipset, WiFi connection used to drop and then re-establish itself every few minutes. ssh sessions and web page loading would freeze and everything was painfully slow but intermittently "working".

Over the course of several days, I tried many solutions, both on the software and hardware side: upgrading drivers, reorienting antenna, moving the wireless card to a further slot to avoid heat from the neighbor graphics card, reconfiguring the WiFi access point to use different channels, try narrower frequency bands to reduce interference from neighbors, changing MTU, disabling power-saving, etc. etc. Trial and error at its extreme.

The breakthrough in my case, came when I realized 2 things:

  • My wireless signal is actually strong and healthy. This was found by using:

    watch iwlist wlan0 scan

  • Before any disconnection occurred, there's was serious packet loss issue. This was found by continuously running mtr in a dedicated window:


(replace with your actual access point IP). Running this mtr in one screen allowed me to quickly verify if any change I make, has an immediate effect on packet-loss. The ability to perform this quick experimentation was key to pin-point the culprit among so many possible variables.

In my case, it was the repeater (aka "WiFi extender") in the hallway. Once turned off, packet loss started dropping towards 0%. YMMV. As it turns out, 802-11n has the ability to integrate multiple weak signals bouncing off walls at slight delays to amplify the signal. In my case, I figured the repeater was introducing a too big delay causing almost exactly one in 3 packets to be received in error.

As you can see from the large number of answers here, many people have a similar problem, but the reasons are different. The key to any eventual solution may be simply the ability to quickly experiment and test hypotheses. A continuous mtr monitoring the packet-loss rate while changing parameters at the same time did it for me. I highly recommend this as a diagnostic approach.


I do own a X121e too. I have switched my WLAN to g-mode only. Now my Wlan connection is quite stable (working for about 1 hour without disconnect). Maybe the switch between b-mode, g-mode and, n-mode is part of the problem.

  • Is it possible to do this from the client-side?
    – Thomas
    Jan 21, 2012 at 12:02
  • I did not find an option to force the realtec card to use only g network.
    – Nomadic
    Jan 21, 2012 at 16:24
  • I cannot switch to g-only, just to bg-only (without effect - problems are still there)
    – Thomas
    Jan 22, 2012 at 18:28

Update for Ubuntu 12.04:

I have the same problem as before with the buildin driver of Precise Pangolin. What is working more stable than anything I tried with Oneiric is the driver from realtek's website. I'm using the latest version (0005.1230.2011). This version did not work well for me with Oneiric (suspend did not work). With Precise it work's fine and the problems are mostly gone. From time to time (once every two days maybe) the wireless connection stops working as before, but not nearly as often as before.


I have the same issues with X121e. I have the problem that the function keys were swaped after standby and the wireless randomly disconnects.

Then my mainboard was broken and I sent the notebook back to lenovo which replaced the mainboard. And after that everything worked fine. All my problems were gone! Until I reinstalled Kubuntu and all the problems are back.

Maybe this helps more to understand

  • 1
    So what you're trying to tell us? Please give a brief conclusion.
    – cauon
    Oct 8, 2012 at 16:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .