0

I have a package, which requires libicu55, when I try to install it in Ubuntu Zesty, it gives me this error: Depends: libicu55 (>= 55.1-1~) but it is not installable.

However, I have libicu57 installed, which is obviously a newer version. Also, libicu55 is only available for Xenial.

What do I do about that?

  • I have a package – which one? – dessert Sep 6 '17 at 15:32
  • Download it from the source security.ubuntu.com/ubuntu/pool/main/i/icu/… and install it using sudo dpkg -i libicu55_55.1-7ubuntu0.2_amd64.deb – Redbob Sep 6 '17 at 15:34
  • 1
    If this package is yours, @SlavaFominII, then yuo need to update the package to use libicu57. If it is not yours, you need to contact the people who created teh package to have them make a Zesty-compatible package. – Thomas Ward Sep 6 '17 at 15:36
  • Not exactly that, @ThomasWard. Avidemux, e.g, has no packages for Zesty, but I install it when I apply earlier versions of some packages. – Redbob Sep 6 '17 at 16:36
  • Thank you for the suggestions. I've decided to use portable version of the software in the end and therefore can not verify Redbob's solution, however it looks like a valid option. I'm going to rename the question and leave it for someone who would like to document the possible solutions. – Slava Fomin II Sep 6 '17 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.