6

I am using Ubuntu 17.10 with Wayland. It is detecting my Wacom tablet and I can use it for free painting, but the pen does not take over the main cursor, so I can see 2 cursors.

Seeing them would not be an issue, but if I want to paint straight line in MyPaint for example, it automatically takes the second cursor as start of the line, which makes it impossible to paint straight lines.

Is there a way to disable the second cursor and have only one when I use the pen?

3

Having two cursors when using a tablet in Wayland is by design, but the problem you describe could be due to the fact that you're using X applications on Wayland (using XWayland). Tablet support for X applications under Wayland will be included in the upcoming Xorg 1.20, which will be released in 2018. Until then, you're better of using Xorg. Now, I don't know or use MyPaint myself, so if MyPaint is actually a native Wayland application, my answer does not apply.

| improve this answer | |
0

I had a similar problem. When I tried using my Wacom tablet the second cursor doesn't work - it was hidden or had an offset. After checking the Pre-released updates option under Developer Options tab in Software and Updates and after updating my packages I have only one cursor and everything seems to work.

enter image description here

| improve this answer | |
  • Did not help. Only thing that works so far is to revert to X.org. – tikend Oct 23 '17 at 7:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.