0

I am on another computer, also running Ubuntu 16.04, and need to access my old HDD (a 120Gb SSD) to get some files for backup.

When inserting the USB (the HD as an external drive) the graphic Ubuntu interface shows a folder, but it is only the 511Mb boot-partition. The path is something like

/media/myname/9bee303f-0713-48bb-b897-fee19a1de800

So, perhaps, I need to mount the other 2 partitions to see my files?

With the Disks application, I can see something like

  • /dev/sdb1 = 511Mb. Content Ext2 (v 1.0) mounted at /media/myname/9bee303f-....
  • /dev/sdb2 = 120Gb. No mount.. only says "extended"
  • /dev/sdb5 = 120Gb. No mount.. only says "Linux LVM"

PS: all = "Master Boot Record"

Does it make sense to have 120Gb twice, what can I mount, sdb2 or sdb5?


I would really like a command line answer with warnings about any possible risks of running the commands. If I can apt install a reliable and safe graphical application to help me, that would also be OK.


This isn't a duplicate of the linked post because it doesn't have a direct solution for my context:

  • I don't need a clone; I only need some files off the old filesystem.
  • I am not using Fedora in 2014, I am using Ubuntu 16.04 in 2017

Trying suggestions:

After sudo apt install lvm2 I ran sudo vgscan but:

 /run/lvm/lvmetad.socket: connect failed: Arquivo ou diretório não encontrado
 WARNING: Failed to connect to lvmetad. Falling back to internal scanning.
 Reading all physical volumes.  This may take a while...
 Found volume group "ubuntu-vg" using metadata type lvm2
15
  • sdb1 & sdb2 are primary partitions. you can only have max 4 primary partitions; which was seen as a problem hence they created extended (a primary partition that allows subdivision allowing more than 4 secondary partitions). your sdb2 is an extended made up of potentially many secondary-partitions (you have only one sdb5). sdb2 is a 'logical' partition that has NO real data as its allocated to the secondary-partitions within it. ubuntu is using 'msdos' formatting here anyway; so same as in windoze... mount sdb5 (where data is!) – guiverc Sep 6 '17 at 12:07
  • 2
    @guiverc You are right with most of that but note that /dev/sdb5 is an LVM partition. It cannot be mounted directly. – Melebius Sep 6 '17 at 12:20
  • 1
    Well you do not understand what makes a question a duplicate. The question is a duplicate and just because you are running Ubuntu and need to change the name of your LVM volume does not make your question in any way "unique". If that were the case we would have to re-write each answer for each version of Ubuntu and each UUID of each partition needing to be mounted. – Panther Sep 6 '17 at 16:43
  • 2
    You need to follow the directions to activate and mount LVM. If that fails you need to re-phrase your question with the error messages you get. "Found volume group "ubuntu-vg"" so mount "ubuntu-vg" . – Panther Sep 6 '17 at 16:45
  • 1
    @peterkrauss - I have posted a guide on the linked duplicate question. Importantly, what I would recommend as safest solution is to either (a) attach that disk as primary, boot from it, and use an external to backup what you need; (b) attach the disk to some system which has a primary drive you don't really care much about (e.g. an old laptop setup just for the recovery); (c) attach to a virtualbox VM and mount there where it won't affect your base host OS. Reason being - things can go wrong and you don't want to risk losing data on 2 drives if you make any mistakes. – Brandon K Sep 19 '17 at 2:46
1

Adapting and using half of this solution.

Step 1 - at terminal

I need to read the external disk at sdb5 and not be confused with my main disk and system. Lets use the name Ana for this external disk.

  1. sudo apt install lvm2
  2. sudo vgscan (sudo lvdisplay and sudo fdisk -l)
  3. sudo vgrename /dev/ubuntu-vg /dev/ubuntu-vg-ana
  4. turn off and turn on the external disk (supposed Ana)
  5. check again sudo vgscan to see ubuntu-vg-ana
  6. sudo vgchange -ay ubuntu-vg-ana

And only it, not need more (!).

Step 2 - at Nautilus

After step 6 above, use filesystem GUI (Nautilus) to see the disk with the ~120 Gb. navigate there... Copy from there (external disk) to the main disk, to backup the files.

2
  • Hi @Melebius, it is a kind of "subset solution", but need reliable procedure, it is not a playground where we can do some tests. Please review your donwvote and comments about "duplication". – Peter Krauss Sep 6 '17 at 14:55
  • 2
    I haven’t voted to this question and answer yet, neither up or down. According to this answer, you have successfully solved your problem using the instructions from answers to the question I linked – that‘s exactly what makes this question duplicate. Of course, you may need to change some identifiers but I cannot believe it to be such a problem for someone with 4k rep on Stack Overflow. – Melebius Sep 6 '17 at 16:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.