1

I created an encrypted 2TB boot drive using the standard method from an Ubuntu 16.04 LiveUSB.

I am trying to access that 2TB drive from another system (also Ubuntu 16.04.3) which is running from 1TB encrypted boot drive. When I connect the extra (2TB) drive, I am prompted for the password, which I enter correctly, and I get no other message. Everything seems fine.

I look in Nautilus and all I see is the little 511MB boot section of the 2TB drive.

I open Disks and I see the 2TB drive and the graphic shows the following:

2TB drive cofiguration

The problem is that I do not seem to have access to the large 2TB partition, just to the little pre-boot area.

From the image, you can see the lock is unlocked. It says it is unlocked. It says the device is /dev/sdb5.

I tried to mount it using:

mount /dev/sdb5

I got an error:

mount: can't find /dev/sdb5 in /etc/fstab

So, I tried

mount /2tb /dev/sdb5

I got:

mount: only root can do that

So, I tried

sudo mount /2tb /dev/sdb5

I got:

special device /2tb does not exist

As you might guess, I am quite new to Ubuntu. I might be missing something quite simple but it does seem it should be easier to access this drive.

What can I do access the main partition on this 2TB drive?

  • You have used wrong order, please try with sudo mount /dev/sdb5 /2tb – pa4080 Sep 6 '17 at 7:20
  • @pa4080 I get the error: mount: mount point /2tb does not exist – John Sep 6 '17 at 7:31
  • In this case, you should create it. Good place is /mnt directory (or /media), so run sudo mkdir /mnt/2tb, and then sudo mount /dev/sdb5 /mnt/2tb. – pa4080 Sep 6 '17 at 7:33
  • Is there no standard way without memorizing CLI commands? – John Sep 6 '17 at 7:33
  • Yes, you can use the tool Disks. – pa4080 Sep 6 '17 at 7:36
2

How to Mount an Encrypted Partition at Startup via GUI

1. Connect your device and run Disks:

enter image description here

2. Select the device, select the encrypted partition. Don't unlock it yet. From the 'Gears' menu select Edit Encryption Options:

enter image description here

3. Into the dialogue box Encryption Options:

  • Set Automatic Encryption Options to OFF
  • Tick the option Unlock at startup.
  • Enter your Passphrase.
  • Then press OK (and authenticate yourself into the next dialogue).

enter image description here

4. Click on the 'Padlock' icon to unlock your encrypted device:

enter image description here

5. Now select the partition (the inner part) and from the 'Gears' menu select Edit Mount Options:

enter image description here

6. Into the dialogue box Mount Options:

  • Set Automatic Mount Options to OFF
  • Tick the option Mount at startup.
  • Tick the option Show in user interface, if you want.
  • Change the Mount Point.
  • Then press OK (and authenticate yourself into the next dialogue).

enter image description here

7. Now press the 'Play' button to mount your device:

enter image description here

8. Close Disks and restart the system to check the result.

That's it!

  • Let us continue this discussion in chat. – pa4080 Sep 7 '17 at 8:00
  • 1
    This answer works perfectly, unless you are trying to access an encrypted boot drive from another encrypted boot drive. If you are trying to do that, you must rename the volume group of one of the two encrypted boot drives. You can see how to do that here. – John Sep 7 '17 at 15:39
  • Few other topics relevant to Encrypted LVM: [1], [2], [3]. – pa4080 Sep 7 '17 at 17:29
  • Hi, @John. I was outside for few hours :) You are welcome! I'm happy to help. – pa4080 Sep 7 '17 at 17:30
0

the first attempt didn't provide a location so ubuntu searched /etc/fstab for where to mount it & reported it's not there correctly.

your later attempted mount commands tried to load '/2tb' device onto directory '/dev/sdb5' which IS A SPECIAL DEVICE - the error message is correct.... ie. your mount params [here] are in the wrong order.

  • which means the directory /2tb hasn't been created yet. you cmount to an existing directory; so sudo mkdir /2tb & it'll work :) – guiverc Sep 6 '17 at 7:35
0

You report having been asked for /dev/sdb5 password and entered it without error message or being asked for a second time. If that worked, but you partition just didn't get mounted, then there should be a new device in /dev/mapper/, like a symlink /dev/mapper/sdb5_crypt pointing to /dev/dm-0. If so, you can use sudo mount /dev/mapper/sdb5_crypt /mnt/2tb to make your data accessable. I'm not doing these things often enough to know by heart, wether or when Ubuntu 16.04 mounts work automatically, when they work halfway automatically and when Ubuntu doesn't do anything automatically.

If /dev/dm-0 or similar doesn't exist, you might want to read the answers in Mount encrypted volumes from command line?, which I won't repeat here.

TomTomTom

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.