0

computer specs

  • cpu: intel i7-7700k kaby lake
  • graphics: nvidia gfx 1070
  • ram: 16 gb
  • hard drive: 500gb solid state drive x1 and 250 gb solid state drive
  • wifi card: don't use

xubuntu version: 17.04 (latest ubuntu version)

how can i make my os startup faster. it currently takes 3 minutes and 21 seconds to startup. all other distros ive used normally don't take that long.

i ran the following command

systemd-analyze blame

prints

          9.434s NetworkManager-wait-online.service
          1.009s mysql.service
           607ms systemd-resolved.service
           363ms lightdm.service
           362ms dev-sda5.device
           362ms plymouth-quit-wait.service
           300ms apt-daily.service
           115ms systemd-timesyncd.service
            87ms bluetooth.service
            66ms systemd-rfkill.service
            55ms keyboard-setup.service
            55ms networking.service
            51ms snapd.service
            51ms upower.service
            50ms NetworkManager.service
            47ms ModemManager.service
            45ms grub-common.service
            40ms teamviewerd.service
            35ms accounts-daemon.service
            35ms systemd-udevd.service
            34ms systemd-udev-trigger.service
            28ms thermald.service
            26ms systemd-fsck@dev-disk-by\x2duuid-781C\x2dCC89.service
lines 1-23

i looked at this too

dmesg

prints

https://pastebin.com/UrVjtMUm

looks like

[   92.583751] kauditd_printk_skb: 12 callbacks suppressed

is causing the slow startup

more information

user@user-desktop:~$ systemd-analyze
Startup finished in 13.343s (firmware) + 5.114s (loader) + 2.405s (kernel) + 3min 473ms (userspace) = 3min 21.337s
  • Please specify your computer - Brand name and model - CPU - RAM (size) - internal drive (size) - graphics chip/card - wifi chip/card -- and which version of Xubuntu are you running? – sudodus Sep 6 '17 at 2:35
  • Xubuntu (as well as standard Ubuntu and the other community flavours too) should fly on that computer. Are you using any boot option, for example nomodeset? Have you installed a proprietary nvidia driver for the graphics chip/card? Could there be a problem with the systemd part of the startup? I don't know if there might be problems with the dual drive (HDD + SSD). – sudodus Sep 6 '17 at 3:22
  • @sudodus I dual boot with windows 10 and I use grub2 as my bootloader. im using the default boot options. yeah normally linux does. xubuntu is the only distrobution that really struggles to load for me. ive tried elementary os, solus and no issues at all. – Chad Adams Sep 6 '17 at 3:38
  • 1
    1. I suggest that you install a proprietary nvidia driver for the graphics chip/card? ; 2. Have you tried the developing version 'Artful Aardvark' to be released as 17.10 in October? iso.qa.ubuntu.com/qatracker/milestones/376/builds – sudodus Sep 6 '17 at 4:34
  • @sudodus I haven't. Do I have to completely reinstall my os to upgrade to that version? – Chad Adams Sep 6 '17 at 5:37
0

line 820 seems to be a red herring. Where as lines 821-823 of your dmesg indicates that issue may be apparmor denning "/usr/sbin/mysqld".

To check this look in /var/log/syslog via grep apparmor /var/log/syslog. Temporarily downgrade apparmor's enforcement by running sudo aa-complain /usr/sbin/mysqld followed by a reboot and evaluate the output of dmesg. If the boot time improves restore enforcement by running sudo aa-enforce /usr/sbin/mysqld.

To properly configure apparmor for your use of mysqul see the Oracle blog post AppArmor and MySQL. For a deeper look at debugging apparmor see Ubuntu wiki - DebuggingApparmor

Adding an appropriate exception to /etc/apparmor.d/local/usr.sbin.mysqld may solve this portion of the slow boot.

  • That command gives me this pastebin.com/tYH2iUFz not really sure how to add an exception for that. – Chad Adams Sep 6 '17 at 6:12
  • You gotta use sudo apt-get install apparmor-utils to use aa-complaincommand – Chad Adams Sep 6 '17 at 7:11
  • Just tried that and it doesn't work pastebin.com/kJPwk8WV about the same load times. around 3 minutes – Chad Adams Sep 6 '17 at 7:15
  • @J.Starnes, You are welcome to the chat room :-) – sudodus Sep 6 '17 at 7:56
  • Since my answer is wrong. @ChadAdams, Would you add the output of systemd-analyze critical-chain and systemd-analyze plot > ~/plot.svg. to your question? – J. Starnes Sep 7 '17 at 4:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.